Bug 117152 - Crash after undo redo operation
Summary: Crash after undo redo operation
Status: RESOLVED DUPLICATE of bug 117185
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2018-04-22 10:29 UTC by Telesto
Modified: 2018-08-30 10:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SwUndoSaveSection::SaveSection(SwNodeIndex const &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-04-22 10:29:00 UTC
Description:
Crash after undo redo operation (might be related to bug 107975)

Steps to Reproduce:
1. Open attachment 133424 [details] (bug 107975)
2. CTRL+A CTRL+X
3. Delete the remaining image
4. Paste
5. Hold Undo (sorry to lazy to figure out how many times)
6. Hold Redo (sorry to lazy to figure out how many times) -> Crash


Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: 9c4eaa7b81a40d97fe49b85272b40bfeaaf44f86
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-16_03:31:36
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Dieter Praas 2018-04-22 16:45:19 UTC
Reproducible for me with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 2325f9ac789cd12e5ecc9d239baf2558e1d678bb
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-05_00:37:47
Locale: en-US (de_DE); Calc: CL
Comment 2 Xisco Faulí 2018-04-23 09:55:16 UTC
This is an 'inherit from OOo' crash
Comment 3 Xisco Faulí 2018-04-23 09:57:06 UTC
The crash is reproducible from LibreOffice 3.3 up to https://cgit.freedesktop.org/libreoffice/core/commit/?id=2903d85d6197829633d7f96c95cd55821c2c20ff which was reverted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=14d2255cbd254dea6e87a04f747e7d6d3d54ceb9

@Michael Stahl, I thought you might be interested in this one...
Comment 4 Michael Stahl (CIB) 2018-08-30 10:39:35 UTC
this is essentially the same bug as 117185

*** This bug has been marked as a duplicate of bug 117185 ***