Download it now!
Bug 117169 - UI: Microsoft Office document types (.docx, .doc, etc) don't have an icon on macOS
Summary: UI: Microsoft Office document types (.docx, .doc, etc) don't have an icon on ...
Status: RESOLVED DUPLICATE of bug 67874
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Mac OS X (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-23 00:15 UTC by Andrew Hyatt
Modified: 2018-05-10 12:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Hyatt 2018-04-23 00:15:38 UTC
Description:
Microsoft Office document types (.docx, .doc, etc) don't have an icon on macOS. 

They instead show up with the system default document icon. 

This is both in Finder and the window status bar of the open document. 

.odt and similar document types, on the other hand, have an icon. 

Steps to Reproduce:
1. Open a .doc on macOS
2. Notice that there is no icon for it in the window title bar (besides the default one)

Actual Results:  
There is no icon for .doc

Expected Results:
There should be a LibreOffice icon for it


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15
Comment 1 Alex Thurgood 2018-04-23 07:46:06 UTC
I can't reproduce this because I assume that having MSOffice for Mac on my systems abnegates any missing icon representation.
Comment 2 Andrew Hyatt 2018-05-01 15:45:42 UTC
(In reply to Alex Thurgood from comment #1)
> I can't reproduce this because I assume that having MSOffice for Mac on my
> systems abnegates any missing icon representation.

Yes, if MS Word is installed then it's icons will show up for .doc. 

This bug report says that LibreOffice should register its icons for .doc and .docx because it is able to view and edit them.
Comment 3 eisa01 2018-05-10 12:35:21 UTC
This is a duplicate of a previous reported issue.

Bug #56249 may be related

*** This bug has been marked as a duplicate of bug 67874 ***