Bug 117175 - Toolbar overflow menu off-screen in split-screen view
Summary: Toolbar overflow menu off-screen in split-screen view
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: lowest normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2018-04-23 10:16 UTC by Waldo Ribeiro
Modified: 2018-06-26 10:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of off-screen overflow menu (103.94 KB, image/png)
2018-04-23 10:16 UTC, Waldo Ribeiro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Waldo Ribeiro 2018-04-23 10:16:42 UTC
Created attachment 141556 [details]
screenshot of off-screen overflow menu

LibreOffice version: 5.4.6.2
OS: Fedora 27

In split-screen view, if LibreOffice is on the right and the allocated screen area is too small to display the toolbars in their entirety, their overflow menus are displayed off-screen, as seen in the attachment.
Comment 1 Maxim Monastirsky 2018-04-23 10:21:53 UTC
Is this under Wayland?
Comment 2 Waldo Ribeiro 2018-04-23 10:48:53 UTC
(In reply to Maxim Monastirsky from comment #1)
> Is this under Wayland?

Yes.
Comment 3 Maxim Monastirsky 2018-04-23 11:21:11 UTC
Unfortunately this isn't easy to fix, unless we get support from the toolkit (gtk3) for this kind of things. See the upstream gtk3 bug (put in 'See Also'), and also this blog post for the background:

https://blog.gtk.org/2016/07/15/future-of-relative-window-positioning/
Comment 4 Xisco Faulí 2018-06-04 09:39:50 UTC
*** Bug 117421 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2018-06-11 19:40:47 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0da89ede1fee3a9079b7b41ee8b34504ddeb5ee5

tdf#117175 wayland: Make popup windows not show off-screen

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Maxim Monastirsky 2018-06-11 19:52:12 UTC
This seems to work now on our side, but it depends on gtk version from git (gtk-3-24 branch), so users will have to wait for the next gtk release (3.24).
Comment 7 Commit Notification 2018-06-13 21:53:18 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2bfc4cefc21ab18e9ff7cc5fdc743bcc856d103c

Correctly mirror autofilter in rtl ui, tdf#117175 related

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-06-26 10:00:42 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e223e70f5d92e2ed027fc5d449bd790a123acdc2&h=libreoffice-6-1

tdf#117175 wayland: Make popup windows not show off-screen

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.