Bug 117179 - Unable to apply master slide
Summary: Unable to apply master slide
Status: VERIFIED DUPLICATE of bug 116977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-04-23 13:31 UTC by Buovjaga
Modified: 2018-05-28 09:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-04-23 13:31:57 UTC
1. Launch Impress, can be empty without a template
2. Try to apply any master from sidebar

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 14184060bd2249a492ea44d36463914c421e6ce5
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 23rd 2018

Version: 6.1.0.0.alpha0+
Build ID: 104b26b246c94c8c66864b20d00e419d96b15961
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2018-04-16_08:30:15
Locale: fi-FI (fi_FI); Calc: group
Comment 1 raal 2018-04-23 14:39:38 UTC
This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-07 00:28:30 +0200
commit	dfefe448c41921f2f1e54d3f69b8b9e89031d055 (patch)
tree	1aace31054b5740e2faffcbc5de66a791be27f7d
parent	eba4d5b2b76cefde90cb3d6638c736f435023a45 (diff)
SOSAW080: Added first bunch of basic changes to helpers
Comment 2 raal 2018-04-24 05:19:11 UTC
*** Bug 117181 has been marked as a duplicate of this bug. ***
Comment 3 Armin Le Grand 2018-05-09 17:47:02 UTC
@Xisco: You talk about:
- having noting selected
- thus the sidebar shows 'Layouts'
- clicking tese (applying)
? If yes, can no longer reproduce (also: Will need to wait tdf#166993 to be in master...)
Comment 4 Telesto 2018-05-10 08:52:41 UTC
Probably the same as bug 117181. No repro
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Buovjaga 2018-05-10 14:24:58 UTC
(In reply to Armin Le Grand (CIB) from comment #3)
> @Xisco: You talk about:
> - having noting selected
> - thus the sidebar shows 'Layouts'
> - clicking tese (applying)
> ? If yes, can no longer reproduce (also: Will need to wait tdf#166993 to be
> in master...)

Not reproduced anymore. Closing to bug 116977 per suggestions.

*** This bug has been marked as a duplicate of bug 116977 ***
Comment 6 Xisco Faulí 2018-05-28 09:44:20 UTC
I do confirm the problem is fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=91b0d2122bdee361bf5412a42d48ff051159cbf2