Bug Hunting Session
Bug 117181 - CRASH: LibreOffice crashes changes the master slides
Summary: CRASH: LibreOffice crashes changes the master slides
Status: VERIFIED DUPLICATE of bug 116977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-04-23 14:18 UTC by Xisco Faulí
Modified: 2018-05-28 09:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace (38.90 KB, text/plain)
2018-04-23 14:26 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-04-23 14:18:56 UTC
Steps to reproduce:
1. Open Impress
2. Go to the sidebar
3. Click on the 'master slides' button
4. Change the master slide clicking on different ones from 'Available for use' list
5. CRASH

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: e31a5365091d8658ecce374bbc339a9d832e1a15
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2018-04-23 14:19:49 UTC
Regression introduced by:

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-07 00:28:30 +0200
commit	dfefe448c41921f2f1e54d3f69b8b9e89031d055 (patch)
tree	1aace31054b5740e2faffcbc5de66a791be27f7d
parent	eba4d5b2b76cefde90cb3d6638c736f435023a45 (diff)
SOSAW080: Added first bunch of basic changes to helpers

Bisected with: bibisect-linux64-6.1
Comment 2 Xisco Faulí 2018-04-23 14:26:14 UTC
Created attachment 141564 [details]
gdb backtrace
Comment 3 Buovjaga 2018-04-23 14:32:53 UTC
Sometimes it does not crash on first change, so keep clicking...
Comment 4 Julien Nabet 2018-04-23 14:47:55 UTC
Just a suggestion, I don't participate in bug hunting but wouldn't it be relevant to begin bug hunting only once AW080-Regressions will be fixed?
Indeed, I'm afraid that a lot of crash reports will be generated whereas the root cause could be the same.
Not related to this bugtracker but only to bughunting, but I'm also a bit worried about files including a signature (see tdf#117039)
Comment 5 raal 2018-04-24 05:19:11 UTC

*** This bug has been marked as a duplicate of bug 117179 ***
Comment 6 Xisco Faulí 2018-04-26 13:56:27 UTC
Since this is a crash, let's keep this one open...
Comment 7 Xisco Faulí 2018-05-07 16:46:50 UTC
Adding Cc: to Armin Le Grand
Comment 8 Armin Le Grand 2018-05-09 17:48:23 UTC
Can no longer reproduce (also: Will need to wait tdf#166993 to be in master...)
Comment 9 Telesto 2018-05-10 07:45:00 UTC
No repro with
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL

So bug 116974 and not bug 166993

Thanks Armin!

*** This bug has been marked as a duplicate of bug 116974 ***
Comment 10 Telesto 2018-05-10 07:46:39 UTC

*** This bug has been marked as a duplicate of bug 116977 ***
Comment 11 Xisco Faulí 2018-05-28 09:45:53 UTC
I do confirm the problem is fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=91b0d2122bdee361bf5412a42d48ff051159cbf2