Bug Hunting Session
Bug 117232 - Ability to resize tables with mouse
Summary: Ability to resize tables with mouse
Status: RESOLVED DUPLICATE of bug 113603
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Enhancements Cell-Management
  Show dependency treegraph
 
Reported: 2018-04-25 14:12 UTC by Aron Budea
Modified: 2018-06-08 08:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot from Word (27.65 KB, image/png)
2018-04-25 14:12 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-04-25 14:12:05 UTC
Created attachment 141630 [details]
Screenshot from Word

Word has a neat feature that tables have a handle in the bottom right corner, and tables can be resized by grabbing that handle with the mouse (both vertically and horizontally). Columns are resized proportionally. It would be great to have something similar in Writer, because the Columns tab in Table Properties isn't user-friendly, albeit useful if the size to be set precisely.

Dear UX team, what's your take on this feature, are there additional considerations to take into account.

A minor question, should the handle positioning depend on left/right alignment of table on page? In Word it doesn't, but behaves according to the setting.
Comment 1 V Stuart Foote 2018-04-25 14:21:23 UTC
Needs discussion as to implementing the resize of columns and rows, but OK => NEW
Comment 2 Heiko Tietze 2018-04-28 10:37:17 UTC
Would make this a duplicate of bug 113603, in particular I like the solution of comment 3.
Comment 3 Heiko Tietze 2018-06-08 08:35:26 UTC
No objection to comment 2 so making it a dup.

*** This bug has been marked as a duplicate of bug 113603 ***