Download it now!
Bug 117239 - Help: wrong key shortcut (still F4) for datasource display
Summary: Help: wrong key shortcut (still F4) for datasource display
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2018-04-25 21:15 UTC by Gerhard Weydt
Modified: 2018-05-12 22:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
help pages to be corrected (258.78 KB, application/vnd.oasis.opendocument.text)
2018-04-25 21:15 UTC, Gerhard Weydt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Weydt 2018-04-25 21:15:40 UTC
Created attachment 141639 [details]
help pages to be corrected

Obviously there has been a changeover from F4 to Ctrl+Shift+F4 for opening the data source view, some time in the past. This has not been reflected consequently in all help pages (some have been changed, though, and even more than when I checked this some months ago).
I therefore enclose a document including hardcopies of the help pages where the old assignment hasn't been corrected.
Comment 1 Gerhard Weydt 2018-04-26 14:39:31 UTC
I forgot to say that this still persists in version 6.1:
Version: 6.1.0.0.alpha0+
Build ID: 9c4eaa7b81a40d97fe49b85272b40bfeaaf44f86
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-16_03:31:36
Locale: de-DE (de_DE); Calc: group
Comment 2 Jacques Guilleron 2018-04-26 15:31:58 UTC
Hi Gerhard,

I reproduce with
LO 6.0.4.1 Build ID: a63363f6506b8bdc5222481ce79ef33b2d13c741
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Thank you to have reported it.
Comment 3 Olivier Hallot 2018-04-28 13:04:02 UTC
Thank you for the nice report, makes fix much easy to do. Patch submitted.
Comment 4 Sophia Schroeder 2018-04-28 16:11:28 UTC
*** Bug 117292 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2018-04-29 10:03:45 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e159f81ef39cc9b489ba8a5fcd095b65266449c0

tdf#117239 F4 -> Ctrl+Shift+F4
Comment 6 Gerhard Weydt 2018-05-12 22:25:53 UTC
Verified in

Version: 6.1.0.0.alpha1+
Build ID: 58c07ae9829c1d40f0a851d379c126933243fce3
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2018-04-30_12:19:44
Locale: de-DE (de_DE); Calc: group

english help texts are all OK.