Bug Hunting Session
Bug 117246 - RTF import: lost page breaks inside nested groups
Summary: RTF import: lost page breaks inside nested groups
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.1.0 target:6.0.5
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-26 09:12 UTC by Miklos Vajna
Modified: 2018-04-26 14:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document. (98 bytes, application/rtf)
2018-04-26 09:12 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2018-04-26 09:12:27 UTC
Created attachment 141642 [details]
Reproducer document.

Steps to reproduce:

1) Open the attached file.

2) Observe the number of pages in the resulting document.

Expected result: 3 pages, since there are 2 \page control words in the document.

Actual result: the document is only of 2 pages.
Comment 1 Xisco Faulí 2018-04-26 09:18:21 UTC
Reproduced also in Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 2 Miklos Vajna 2018-04-26 09:25:10 UTC
Bisect points out e3f254ab8211fbab7541cde2100a35c875b0c240, and luckily also gives a hint on what to fix. :-)
Comment 3 Commit Notification 2018-04-26 11:24:09 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a93b46e4652e73ed3460e4c66999d94e50db4b7

tdf#117246 RTF import: don't loose page breaks inside nested groups

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-04-26 14:20:12 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fc1ee8a8473beadbf5d364e059bba6c8006562af&h=libreoffice-6-0

tdf#117246 RTF import: don't loose page breaks inside nested groups

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.