Bug Hunting Session
Bug 117251 - Notebookbar Groupedbar not fully painted when focus is lost
Summary: Notebookbar Groupedbar not fully painted when focus is lost
Status: RESOLVED DUPLICATE of bug 106698
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2018-04-26 13:17 UTC by mal
Modified: 2018-10-18 11:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Focus on Calc (500.75 KB, image/png)
2018-04-26 13:17 UTC, mal
Details
Focus on Writer (494.93 KB, image/png)
2018-04-26 13:18 UTC, mal
Details
Windows 7 version (203.78 KB, image/png)
2018-08-07 08:18 UTC, mal
Details
Win 7 menu not repainted image (222.29 KB, image/png)
2018-08-07 08:18 UTC, mal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mal 2018-04-26 13:17:06 UTC
Description:
onfigured Calc and Write with Notebook Bar and added a gtk3 them ( elementary ) via Plasma control centre. The added a background from the personalisation in tools/options ( looks really cool ) placed them side by side as per attached images. When Calc has the focus everything is OK but when Writer has the focus the icons in Calc vanish. Tried it with Impress as weel and it only happens in Calc

Steps to Reproduce:
1.Configure as above
2.
3.

Actual Results:  
Calc menu vanish

Expected Results:
Nothing should happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Doesn't effect functionality as soon as you click on Calc the menu comes back but it looks bad


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Falkon/3.0.0 Chrome/61.0.3163.140 Safari/537.36
Comment 1 mal 2018-04-26 13:17:42 UTC
Created attachment 141649 [details]
Focus on Calc
Comment 2 mal 2018-04-26 13:18:07 UTC
Created attachment 141650 [details]
Focus on Writer
Comment 3 mal 2018-04-26 13:36:35 UTC
Interestingly it only happens when the focus is taken by another LO program. Clicking on Firefox for example and it doesn't happen
Comment 4 mal 2018-04-27 10:28:02 UTC
The images show a openSUSE build of LO but I tried it on Debian and it
does the same.

M
Comment 5 Buovjaga 2018-05-23 14:56:44 UTC
Before I test with a personalised background, can you tell me if this is dependent on the background or does the problem appear without it as well?
Can you also test with a master build:
https://dev-builds.libreoffice.org/daily/master/?C=M&O=D
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 6 mal 2018-08-07 08:18:13 UTC
Created attachment 144007 [details]
Windows 7 version
Comment 7 mal 2018-08-07 08:18:59 UTC
Created attachment 144008 [details]
Win 7 menu not repainted image
Comment 8 mal 2018-08-07 08:20:26 UTC
Sorry for the long delay. Tested it on Windows 7 and it happens the same as Linux
Comment 9 mal 2018-08-07 09:27:10 UTC
Tried 6.1 RC3 on Windows 7
Menu flickers a bit but the 'non redraw issue' seems OK now

M
Comment 10 mal 2018-08-07 10:50:36 UTC
Tried 6.1 RC3 on Debian 8 in Cinnamon and issue still happens

M
Comment 11 Pedro 2018-08-08 11:01:01 UTC
This is with the Groupedbar and groupedbar compact.
I tried this in Windows 10 and could not replicate. Someone should try this in Linux to confirm.
Comment 12 Buovjaga 2018-08-09 12:25:51 UTC
No problem on Linux

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 8a2c7ee13c2045911fb289a8b3976ef395b557f8
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on August 8th 2018
Comment 13 Xisco Faulí 2018-10-18 11:24:27 UTC
Seems like a dupe of bug 106698

*** This bug has been marked as a duplicate of bug 106698 ***