Download it now!
Bug 117292 - UI / native lang DE - Calc: displayed shortcuts doesn´t work
Summary: UI / native lang DE - Calc: displayed shortcuts doesn´t work
Status: RESOLVED DUPLICATE of bug 82117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2018-04-27 15:43 UTC by Thomas Krumbein
Modified: 2019-03-18 11:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
shortcut in German location - not accessable (21.43 KB, image/png)
2018-04-27 15:44 UTC, Thomas Krumbein
Details
german keyboard layout (9.99 MB, image/png)
2018-04-27 18:08 UTC, Thomas Krumbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2018-04-27 15:43:40 UTC
Description:
in modul calc we find the menu-option "insert" and there the two field : "actual date" and "actual time".
both works fine, but there are additional shortcuts displayed, with are not working on German-based keybords (see pic).

Key: "Strg + ;" is not accessible, same for "Strg + Umschalt + ;".



Steps to Reproduce:
1. try it on german keybords
2.
3.

Actual Results:  
Shortcuts do not insert date or time

Expected Results:
correct shortcuts or remove the wrong information


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
that is not a new problem. In Germany we normally assign both fields to "Strg + ," and "Strg + Umschalt + ," - then this is the same behavior than Excel. 

so: remove the information for the shortcut.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Thomas Krumbein 2018-04-27 15:44:31 UTC
Created attachment 141717 [details]
shortcut in German location - not accessable
Comment 2 Jacques Guilleron 2018-04-27 17:33:23 UTC
Hi Thomas,

With
LO 6.1.0.0.alpha1 Build-ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU-Threads: 2; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (fr_FR); Calc: CL

I find in Einfügen:Datum    Ctrl+;
and                Zeit     Ctrl+Shift+;
Those are also the shortcuts defined in
Extra > Anpassen...: Tastatur
Comment 3 Thomas Krumbein 2018-04-27 18:08:25 UTC
Hey Jacques,

yes, thats right:)  

But it is not possible to use this shortcuts on german keybord layout.

I attach a picture of a keyboard. You will see: to get the combination strg * ; you have to press the keys Strg + shift + ; - so this is different to what is expected - the listener will not act.

If you just use strg + , the internal cpode is different to the listener - it doesen´t work either.

So - to use the shortcuts in Germany with german keyboards we change by customer the internal keys to ctlr + , and ctrl + Schift + , - than everything works well (like excel).
Comment 4 Thomas Krumbein 2018-04-27 18:08:59 UTC
Created attachment 141720 [details]
german keyboard layout
Comment 5 Thomas Krumbein 2018-04-27 18:09:39 UTC
and I used for testing LO 6.1.0.0.alpha1 !!
Comment 6 Jacques Guilleron 2018-04-28 08:17:08 UTC
Ok Thomas,

Seen. I understand. Thank you for infos and sorry for the noise.

Jacques
Comment 7 Sophia Schroeder 2018-04-28 16:11:28 UTC
This seems to be a duplicate or at least related to : tdf#117239

Feel free to reopen it in case you think it's not.

*** This bug has been marked as a duplicate of bug 117239 ***
Comment 8 Thomas Krumbein 2018-04-29 05:47:06 UTC
does not have anything to do with bug # bug 117239 !

Please read careful the mentioned infos.

This case here is not a real technical bug, because the standard shortcuts are the same than for years.

But now it is a miss-information because the shortcuts are displayed in menu-items, so a lot of people will try this and it will not work using german keyboards. Then there is a problem with those users!

The easiest way to solve this problem: Do not display the shortcuts on both menu-entries.

If you want to change either the help-pages... fine. no priority. 

But the menu-entries should be changed!

Or better but I believe more difficult: for a german localisation change the default shortcuts :)
Comment 9 Thomas Lendo 2018-04-29 06:10:13 UTC
Hi Thomas, maybe this report is already covered by bug 82117. Several bugs regarding English shortcuts for non-English keyboard layouts are open.

Setting back to Unconfirmed as it never had New status.
Comment 10 Harald Koester 2018-04-30 19:13:29 UTC
Indeed, it is covered by bug 82117. Set to RESOLVED DUPE of 82117.

*** This bug has been marked as a duplicate of bug 82117 ***