Download it now!
Bug 117295 - Main window does not repaint during OLE object "Further objects" type selection (Win 7 only)
Summary: Main window does not repaint during OLE object "Further objects" type selecti...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OLE-Objects
  Show dependency treegraph
 
Reported: 2018-04-27 16:15 UTC by Andy Goth
Modified: 2019-01-16 12:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast of display problem (11.72 MB, video/x-msvideo)
2018-04-28 04:34 UTC, Andy Goth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Goth 2018-04-27 16:15:54 UTC
Description:
While the "Insert Object" window is displayed, the main window does not repaint, so the window leaves behind a trail if dragged on top of the main window.  The "Insert Object" window is posted by selecting "Further objects" from the "Insert OLE Object" window, which in turn is posted by selecting "Insert > Object > OLE Object" from the menu.

The main window resumes normal repaints after a selection is made from the "Insert Object" window.

Steps to Reproduce:
1. Insert > Object > OLE Object
2. Further objects, OK
3. Drag windows over top of main window

Actual Results:  
Main window does not repaint exposed areas

Expected Results:
Main window should repaint exposed areas


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Xisco Faulí 2018-04-27 16:41:11 UTC
Could you please create and attach a screencast showing the steps?
There are various free screencast software available for use, including Camstudio (Windows), Jing (Mac), Simple Screen Recorder (Linux) or screencast-o-matic.com (Web).
Comment 2 Andy Goth 2018-04-28 04:34:59 UTC
Created attachment 141732 [details]
Screencast of display problem
Comment 3 Buovjaga 2018-06-07 14:48:23 UTC
I can reproduce this on Windows 7, but not on 10. Tried 6.0.4 and latest master.
The Further objects seems to be Win-only anyway (not found on Linux)

It is not yet in 4.4.7. I might try a bibisect later.
Comment 4 Buovjaga 2018-06-07 17:34:36 UTC
Bisected with Win 6.0 repo to https://cgit.freedesktop.org/libreoffice/core/commit/?id=fb4e7be5d4eac6d7c429c215e72de45ea28d86cd

commit	fb4e7be5d4eac6d7c429c215e72de45ea28d86cd (patch)
tree	82b4d4282baa970cbc6990d77b5f7ac3451aa3af
parent	21ccc64782f485f4fce7cd645f24dabb4b6eb985 (diff)
WIN another system loop integration attempt
This time we skip the intention to handle our Scheduler
completely via the system event loop. Instead we basically
guarantee to process a Scheduler event during each DoYield,
if one is available. This way we won't block system events
when busy in our event loop.

Change-Id: I37094e61cbf928733151d9cc3299cdac76b3a5cd
Reviewed-on: https://gerrit.libreoffice.org/43349

Adding Cc: to Jan-Marek Glogowski

Bug 116615 blamed the same commit
Comment 5 Commit Notification 2018-12-12 22:11:48 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5bb798a99e7b178ac57ee8c15238534723000bf9%5E%21

tdf#117295 WIN no main loop shortcut for OLE dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-12-14 15:22:28 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3e3c3619fe695fea25d10a9bae0442317feca0cd%5E%21

tdf#117295 WIN no main loop shortcut for OLE dialog

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-12-26 13:39:11 UTC
Verified in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

@Jan-Marek Glogowski, thanks for fixing this!!
Comment 8 Commit Notification 2019-01-16 12:06:20 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/3376b0e94f0638c927a37c32322bf67d42ebb00f%5E%21

tdf#117295 WIN no main loop shortcut for OLE dialog

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.