Download it now!
Bug 117310 - CONFIGURATION: Missing command for Word Completion: Adjusting number of characters have to enter, before proposal is shown.
Summary: CONFIGURATION: Missing command for Word Completion: Adjusting number of chara...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2018-04-28 09:32 UTC by Christoph Bartz
Modified: 2018-06-10 21:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartz 2018-04-28 09:32:26 UTC
Description:
org.openoffice.Office.Writer 
 → AutoFunction
 → Completion 

In Writer I use Word Completion. Proposals for Word Completion are shown after typing 3 characters. Unfortunately there is no option to adjust this. In my opinion it is too soon, word proposals are shown far too much. I would adjust this, so that proposals for word completion are shown after typing 5 characters (for example).

Well, could somebody add this option? Thank You.

Steps to Reproduce:
1. Options Auto Correction
2. Word Completion
3.

Actual Results:  
(see despription)

Expected Results:
(see description)


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Xisco Faulí 2018-05-30 09:23:03 UTC
Hi Christoph,
You can change it from Tools - AutoCorrect - AutoCorrect Options - Word Completion.
Closing as RESOLVED NOTABUG
Comment 2 Christoph Bartz 2018-05-30 18:46:58 UTC
Hi Xisco Faulí,

thank You for your answer. But unfortunalety your answer is not correct.

As I said, I want to adjust the number of characters, before a word completion proposal is shown in the text file while writing. Currently there is (really) no option to adjust this.

An example:
1. Open Writer. 
2. Acivate AutoCompletion, check Collect Words.
3. Type the word »exepletiveword« in the text file. Enter.
-> Now LibO Writer has automatically saved the word »exepletiveword« as an entry in the Auto Completion word list.)
4. Type »exe«. 
-> Now LibO Write shows the proposal »exepletiveword«. Fine, Auto Completion works.

But - and that is my point - Writer always shows proposals after typing 3 characters (in this case »exe«). I want to change this, so that Writer shows a proposal after typing 6 characters for example, in this case it would be »exeple«. 

That would be a nice enhancement for the tool Auto Completion. Of course it is not a bug (see category »Importance«).
Comment 3 Jean-Baptiste Faure 2018-06-10 21:05:42 UTC
Valid enhancement request, so status set to NEW.

That said I disagree with this request, I think it is useless. Word completion is useful if you have to type as few as possible characters before a completion proposal is shown. If you receive too many completion proposals, you should disable word completion.

Best regards. JBF