Download it now!
Bug 117319 - Bibliography character styles are reset to default when closing Bibliography editor via ‘Ok’ without doing any actual changes
Summary: Bibliography character styles are reset to default when closing Bibliography ...
Status: RESOLVED DUPLICATE of bug 64891
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2018-04-28 17:24 UTC by jakrvir
Modified: 2018-06-07 14:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple Bibliography with Emphasis style (13.15 KB, application/vnd.oasis.opendocument.text)
2018-04-28 17:27 UTC, jakrvir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jakrvir 2018-04-28 17:24:34 UTC
Description:
I added bibliography entries and a Bibliography at the end of the document, and then modified the character styles of the entries title component to show in Italic (or Emphasis). After modifying the styles, they show correctly.

If I now click ‘Edit index’ on Bibliography but close the opened dialog immediately via ‘Ok’ button without doing any actual changes, the styles are reset to default (or something that seems like default). The styles will reset also if I just click ‘Update index’ on Bibliography. 

Clicking Bibliography > Edit index > Close doesn’t reset the styles.

The current behavior is unfortunate, since Bibliography style guides often recommend Italic format for emphasis for certain components. References also often change at the last minute so it’s not a complete solution to try apply the styles only after the document is in some presumed final form.

Note: Only character styles that were tested were Emphasis and Teletype, but it’s probable the problem involves all the default styles. Custom styles were not tested.

Note2: Attached is Writer .odt file with two Bibliography entries and Bibliography for quick testing. The entries should initially have the styles shown, but they will be reset when doing the steps 8-10 or when updating the index.


Steps to Reproduce:
1. Create new empty Writer document

2. Add bibliography entry (Insert > Table of Contents and Index > Bibliography Entry)
- Choose ‘From document content’
- Click New, then set Type as Book, give Short name, Author, Title and Year
- Click Ok > Insert

3.Add Bibliography to document (Insert > Table of Contents and Index > Table of Contents, Index or Bibliography)
- Select Type: Bibliography
- Select tab: Entries
- Select Type: Book and Select element Ti in ‘Structure and Formatting’
- Set Character style to Emphasis
- Click Ok
4. Confirm that title in Bibliography entry is shown as Italic (Emphasis)
5. Save the document and close Writer
6. Restart Writer and open the saved document
7. Confirm the Bibliography entry has still Italic style
8. Click Bibliography > Edit index
9. Click Ok without changing anything
10. Confirm that Bibliography entry has no longer Italic style 

Actual Results:  
Italic style has been reset to default or something similar looking.

Expected Results:
Italic styles should persist over Edit index -> Ok


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no

Version: 5.4.5.1 (x64)
Build ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: fi-FI (en_FI); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 jakrvir 2018-04-28 17:27:30 UTC
Created attachment 141744 [details]
Simple Bibliography with Emphasis style
Comment 2 Buovjaga 2018-06-07 14:27:03 UTC
I think this is essentially the same as bug 64891

*** This bug has been marked as a duplicate of bug 64891 ***