Bug 117337 - Special Character dialog: Impossible to focus the character table with the Tab key
Summary: Special Character dialog: Impossible to focus the character table with the Ta...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: accessibility, bibisected, bisected, regression
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2018-04-29 19:55 UTC by Adolfo Jayme
Modified: 2019-04-24 13:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2018-04-29 19:55:51 UTC
Approximately since this dialog was “welded” (I didn’t bisect this; it’s just when I first observed this), now it’s not possible to focus the character grid by Tabbing your way to it. The only way to focus it is by clicking one of its characters; then, you’re able to use the arrow keys (←, →, ↑, ↓) to change the selected character.

If the character grid is not focused, the glyph preview at the right side doesn’t change (this is another bug that is already reproducible in 6.0.x).
Comment 1 Telesto 2018-04-29 21:15:46 UTC
Repro
Version: 6.1.0.0.alpha0+
Build ID: 2ed7c02478968852d7d39c2c4677f2ecf3441bc7
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-22_01:00:56
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Xisco Faulí 2018-04-30 14:09:17 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2018-03-22 13:41:50 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-03-30 14:32:12 +0200
commit	374599f8c26713905a310673d2b429083321186a (patch)
tree	2ee4be182670b2ca9396a5f42d4122bed806a3ba
parent	2d3a5e81e9730c1190f8592f85f5b99b6d4587ef (diff)
weld SvxCharacterMap dialog

Bisected with: bibisect-linux64-6.1 

Adding Cc: to Caolán McNamara
Comment 4 Xisco Faulí 2018-05-02 10:46:48 UTC
Verified in

Version: 6.1.0.0.alpha1+
Build ID: 43af818557904450b13839350c65ad865b9ee9d2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Caolán, Thanks for fixing this!