Download it now!
Bug 117383 - [GTK3] UI becomes grey if a large video is played
Summary: [GTK3] UI becomes grey if a large video is played
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-05-02 10:12 UTC by Xisco Faulí
Modified: 2019-06-10 09:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
How it looks in LibreOffice 6.1 master (465.15 KB, image/png)
2018-05-02 10:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-05-02 10:12:02 UTC
Created attachment 141831 [details]
How it looks in LibreOffice 6.1 master

Steps to reproduce:
1. Open 140574 from bug 116345
2. Select the video
3. Play it

Observed behaviour: Everything around the video become grey. Scrolling the window has an unexpected behaviour as well. The problem remains if we go to the start center or to another component.

This is not reproducible if we zoom out the slide before playing the video...
Not reproducible in GTK nor GEN

Reproduced in

Version: 6.1.0.0.alpha1+
Build ID: 43af818557904450b13839350c65ad865b9ee9d2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 1 Xisco Faulí 2018-05-02 10:13:16 UTC
Caolán, I thought you might be interested in this one...
Comment 2 Caolán McNamara 2018-05-02 11:32:42 UTC
Might be using the fallback if the gstreamer gtk integration is not installed, for me I have...

/usr/lib64/gstreamer-1.0/libgstgtk.so (from fedora 27 gstreamer1-plugins-bad-free-gtk-1.12.4-1.fc27.x86_64) installed and I don't get the all-grey look you get. 

What's your distro and is that libgstgtk.so there, and if not, is it available via some package or other ? If it was that problem its possibly to add specific requires to our upstream rpms to make it a requirement
Comment 3 Xisco Faulí 2018-05-02 12:16:40 UTC
Hi Caolán,
I have Linux mint 16.04 with gstreamer 0.10.36-1.5ubuntu1 and 1.8.3-1~ubuntu0.1 ( with gstreamer1.0-plugins-bad ) but I can't find libgstgtk.so
Comment 4 Caolán McNamara 2018-05-02 12:41:39 UTC
Maybe /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstgtksink.so ?
Comment 5 Xisco Faulí 2018-05-02 13:43:18 UTC
(In reply to Caolán McNamara from comment #4)
> Maybe /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstgtksink.so ?

Yes, that lib exists in the same folder you're mentioning...
Comment 6 Caolán McNamara 2018-05-02 14:37:23 UTC
Got the best available renderer in place then, so possibly I'm insulated from this by using wayland or there's something else gone wrong, like event starvation or some such
Comment 7 Buovjaga 2018-06-07 17:42:52 UTC
Repro with X session.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 67aaa98600269e6b8fa631146c3649a261369471
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 7th 2018
Comment 8 QA Administrators 2019-06-08 02:53:01 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2019-06-10 09:22:07 UTC
No longer reproducible since the video is played in another window in

Version: 6.4.0.0.alpha0+
Build ID: ec905d131374f0860bac77c52873eed984b1966f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded