Download it now!
Bug 117406 - UI color palette and Recent Colors in (Table properties) not accessible via key board, dropped TAB focus
Summary: UI color palette and Recent Colors in (Table properties) not accessible via k...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: accessibility, bibisected, regression
Depends on:
Blocks: Color-Palettes
  Show dependency treegraph
 
Reported: 2018-05-03 11:45 UTC by Cor Nouws
Modified: 2018-05-05 13:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2018-05-03 11:45:29 UTC
Writer document + white table
menu Table > Properties
tab Background
TAB twice, SPACE 
  >  Color activated, OK
TAB twice
  > focus on list box Palette, OK
TAB  to go to palette itself ..
 > does not work

Try to go to Recent Colors
 > does not work either

Seen in Version: 6.1.0.0.alpha1+
Build ID: 8a2745e1beee722c8c9691c397e493cc1160bedf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-30_23:34:23
Locale: nl-NL (nl_NL.UTF-8); Calc: group

but prolly a bit older.
Comment 1 V Stuart Foote 2018-05-03 20:44:26 UTC
Can not confirm...

On Windows 10 Ent 64-bit en-US with
Version: 6.1.0.0.alpha1 (x64)
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group

Using keyboard:  F10 -> A (T_able) -> P (_Properties) -> Alt+C (~Color) -> Alt+P (~Palette) then TAB

And while TAB gets you to the pallet's grid, because color was NONE there is no indicator of a color selection. Until simply move the cursor UP,DOWN,LEFT,RIGHT in the pallet chart--the New RGB swatch will update.

Likewise, if you TAB one stop further onto the Recent colors pallet bar, no indicator--but the DOWN, LEFT RIGHT cursor movements work and refresh the New RGB swatch in the dialog.

On Windows builds this works as expected.
Comment 2 V Stuart Foote 2018-05-03 22:47:40 UTC
Oops, sorry Cor, that was the Alpha1 release. 

But on Windows 10 Ent 64-bit en-US current master, TAB onto the picker was fine for the 2018-04-30 build, but is bad on the 2018-05-01 build.

https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=5f2073fbc995fb619f398a55187413813578b62e..3e5e7a6017334e15c1f4a67d484dba06408627bd

@Caolán, seems likely a weld issue for one of the table dialogs touched in that period.
Comment 3 Caolán McNamara 2018-05-04 15:26:22 UTC
they have incorrect can_focus props set which becomes a problem now we use that setting
Comment 4 Commit Notification 2018-05-04 20:13:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6bbaed858821bc32bd1fec6915f72bfc093b0a16

Resolves: tdf#117406 cannot tab into colorsets, cause can_focus was False

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 V Stuart Foote 2018-05-05 13:55:51 UTC
Yup, TAB navigation onto the color widgets restored now.

Version: 6.1.0.0.alpha1+
Build ID: 0b56585cfc047decf25c648d3cccfc3c7b594a86
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-05_05:23:29
Locale: en-US (en_US); Calc: CL