Bug 117414 - CRASH - on attempting to load a writer template document (OSX)
Summary: CRASH - on attempting to load a writer template document (OSX)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2018-05-03 14:49 UTC by pascal.gouhier
Modified: 2018-12-11 20:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document .ott which crashes LO (18.80 KB, application/vnd.oasis.opendocument.text-template)
2018-05-03 14:50 UTC, pascal.gouhier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pascal.gouhier 2018-05-03 14:49:35 UTC
Description:
One of my template document can't be opened any more with LibreOffice version >5
It's very specific to one template but i can't explain what is troubleshoting as even in erasing all is content, it crashes. Others don't crash. Even if i recreate the same template from scratch, it crashes, but on Mac only.

Steps to Reproduce:
1.open the .ott document
2.LibreOffice start and crash
3.The End

Actual Results:  
Crash

Expected Results:
Having a new document from the template.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
When I attempt to open this document in edition mode, the template doesn't crash.

About OpenGL : with or without doesn't make any difference.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 pascal.gouhier 2018-05-03 14:50:48 UTC
Created attachment 141871 [details]
Document .ott which crashes LO
Comment 2 Xisco Faulí 2018-05-03 15:58:15 UTC
Reproduced in

Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 8; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group

and back to 

Version: 5.3.5.1
Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
CPU Threads: 8; OS Version: Mac OS X 10.13.3; UI Render: default; Layout Engine: new; 
Locale: en-US (en_ES.UTF-8); Calc: group

but not in

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 8; OS Version: Mac OS X 10.13.3; UI Render: default; Layout Engine: new; 
Locale: en-US (en_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2018-05-03 16:06:43 UTC
I can't reproduce the issue with the bisect repositories, sigh!!
Comment 4 Xisco Faulí 2018-05-04 10:15:24 UTC
> Version: 5.3.5.1
> Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
> CPU Threads: 8; OS Version: Mac OS X 10.13.3; UI Render: default; Layout
> Engine: new; 
> Locale: en-US (en_ES.UTF-8); Calc: group

I've compiled the same commit locally

Version: 5.3.5.1
Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
CPU Threads: 8; OS Version: Mac OS X 10.13.3; UI Render: default; Layout Engine: new; 
Locale: en-US (en_ES.UTF-8); Calc: group

and it doesn't crash!! this is really strange...

@Tor, I thought you might be interested in this issue. it seems to happen only with release builds...
Comment 5 Tor Lillqvist 2018-05-17 06:19:36 UTC
I can't reproduce it with LibreOffice Vanilla 6.0.3 or 6.0.4 (which certainly are "release" builds, for all meanings of "release").
Comment 6 Tor Lillqvist 2018-05-17 06:21:45 UTC
And not with a non-sandboxed optimised (i.e. in that sense "release") build from April that I had on disk either.

Or maybe I am holding it wrong; when the description says to "open" the .ott document, it means Command-O, or something else? (I never use ODF templates for real, so I might be missing something...)
Comment 7 pascal.gouhier 2018-05-17 08:55:37 UTC
When i say "open" a template document, it's or double-clic on the document, or open from a template (File->new->models menu or something like that as I use it in French), or from the startup screen using models menu.
That action have to open a new .odt document whith the content of the model and with this document, LO crashes.
Comment 8 eisa01 2018-12-11 20:22:04 UTC
This works for me, I can open the template without issues as well

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group threaded