Bug Hunting Session
Bug 117420 - NAVIGATOR .. create "OUTLINE DOCUMENT" -- the next stop after SEND → OUTLINE to Clipboard
Summary: NAVIGATOR .. create "OUTLINE DOCUMENT" -- the next stop after SEND → OUTLINE ...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2018-05-04 05:27 UTC by peter josvai
Modified: 2019-07-31 18:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2018-05-04 05:27:25 UTC
dear developers, 

we are totally aware of the fact that free software dev teams have an ego...
see how long it took for Mozilla's Firefox to put the "refresh" button to where it ergonomically belongs... only because of the corporate competitor, Google Chrome had it there already...
we can sense sort of the same underlying the development of Libreoffice's Writer's NAVIGATOR function ... only because of the corporate competitor's presence..


In any case, THE OUTLINE VIEW (which we keep begging for) (and won't stop :))
is unreasonably, even irrationally buried in the "SEND" menu..
what does copying the outline of a doc have to do with sending, in the first place?

the entire group:

EXPORT
EXPORT as
SEND
Preview in Web Browser

is illogical to a significant extent..

::::::::::::::::::::::::::::::::::::::::::::

SUGGESTION for the next step, next stage:

"outline" should be in the Navigator's menu..
when viewing "headings"
in the dropdown 
(outline level
drag mode
display)

there should be: copy outline to clipboard

::::::::::: 2 (one step further)
an OUTLINE DOCUMENT could be created
(NOTE: not "document outline" !!! but "an OUTLINE document" !!)

like a TOC...

and this document -- the outline document)
would be UPDATED in real time
but only one way... by editing THE document...
and it would be in the same directory, locked by the same "locking file"..
it should be renamable (so that you could find it easily in the directory)
and once the document is moved somewhere...
the "CREATE the OUTLINE DOCUMENT" button / menu item would be active again, 
that is, it would lose its previous "outline document" as an exported copy of it..

::::::: toolbars
the toolbars can be made to disappear altogether...
and a special new toolbar, OUTLINE, could be introduced... 
and that would be visible only in the outline document's window...

and it would offer very minimalistic editing only:
a quick  SAVE a COPY AS exporting button, for example



::::::: commenting
it would be nice if we could add notes, comments to the outline document
in such fashion that the NOTE would appear under the heading of the section..

:::::: behavior
when the heading is rewritten, it would be rewritten in the OUTLINE Document, too, in real time...
BUT when it is cut out, and there are notes under it in the OUTLINE document, 
the "deleted heading" would be left there in gray color... for example...
I mean, "grayed"... (as a larger block of "commented out" text)
which then could be manually, intentionally deleted... but also kept...



please excuse me for the length...

thanks for your work!


Peter
Comment 1 Heiko Tietze 2018-05-08 09:38:28 UTC
(In reply to peter josvai from comment #0)
> "outline" should be in the Navigator's menu..
> when viewing "headings"
> in the dropdown 
> (outline level
> drag mode
> display)

I don't get this Navigator menu. Are you talking about the F5/Sidebar-Navigator or a main menu entry?

And everything below starting with "=== toolbars" looks like a different question. Please file only one issue per ticket.
Comment 2 Thomas Lendo 2018-09-24 19:19:55 UTC
Thanks for your bug report.
Feels like the outline view in Impress.

Part of this seems to be a dupe of Bug 38093 'Functionality request for Writer: Add Outliner similar one in Impress as basis for outlining component'.

A similar bug was Bug 119877 'WRITER, NAVIGATOR -- easy access (right click) to "send outline to clipboard" functionality' where the position of send outline was discussed.

I don't like the idea of a separate document. Sounds complicated and unpracticable because of odf specification.

Maybe Bug 47746 'Collapse or expand parts of a document' would help you.
Comment 3 Cor Nouws 2019-07-31 12:11:49 UTC
Hi Peter,
(In reply to peter josvai from comment #0)
> In any case, THE OUTLINE VIEW (which we keep begging for) (and won't stop :))
> is unreasonably, even irrationally buried in the "SEND" menu..
> what does copying the outline of a doc have to do with sending, in the first
> place?
This sends the Outline of the document to e.g a presentation. So it is unrelated to the view.

> "outline" should be in the Navigator's menu..
> when viewing "headings"
> in the dropdown 
> (outline level
> drag mode
> display)
> 
> there should be: copy outline to clipboard
Could be a nice _addition_ I think :)

(I think the rest of your ideas are about whole new functionality).
Comment 4 Heiko Tietze 2019-07-31 18:16:46 UTC
(In reply to Cor Nouws from comment #3)
> Could be a nice _addition_ I think :)

So let's close this ticket whether it's a insufficientdata or worksforme. Anyone can reopen the ticket and at least wouldn't close it then anymore.