Bug Hunting Session
Bug 117465 - cutting and pasting from Office 365 docx document to LibreOffice using Windows 10 x64 clipboard intermittent at best
Summary: cutting and pasting from Office 365 docx document to LibreOffice using Window...
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Paste-From-MSO
  Show dependency treegraph
 
Reported: 2018-05-07 01:26 UTC by DoctorBob4390
Modified: 2019-09-20 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DoctorBob4390 2018-05-07 01:26:31 UTC
Description:
When cutting and pasting from Office 365 Word docx document to a LibreOffice template only works part of the time. Using mouse right click and copy from menu results in no paste options available in LibreOffice. Using Control+C from the keyboard on highlighted docx text results in no paste options available. Using Control+C followed by Control+Y will intermittently allow pasting in LibreOffice document

Steps to Reproduce:
1. Open Office 365 Word docx document
2. Highlight text to be coppied with mouse
3. Right click highlighted text in Word 365 and select copy
4. click placement position in LibreOffice Writer document and right click mouse.


Actual Results:  
Paste function is grey and Paste Special = No Options Available

Expected Results:
Past function should be black and Paste Special should allow selection between formatting


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
Operating System is 64bit


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36 Edge/16.16299
Comment 1 Dennis Roczek 2018-06-08 12:29:18 UTC
Hi,

I cannot reproduce this using 
Version: 6.0.4.2 (x64)
Build-ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL

and MSO Word 2016 O365.

Which version do you use (LibreOffice)? Can you try 6.0.X?
Comment 2 QA Administrators 2019-01-11 15:23:06 UTC Comment hidden (obsolete)
Comment 3 DoctorBob4390 2019-01-12 06:59:44 UTC
The problem has continued to persist through both Windows 10 Pro x64 updates, Office 365 updates and newer versions of LibreOffice. Cutting from pages displayed in either Edge or Internet Explorer paste as normal within LibreOffice Writer. However, when cutting and pasting from a Word docx document in Office 365 to a LibreOffice template or document it is extremely rare that I am able to paste the content from the clipboard. 

Procedures used when bug occurs:
Using the mouse to highlight text in Office 365 document and right clicking on the mouse allows "copy" from the drop down menu to place data on clipboard...This was tested by replicating the copied material in the document from which it was coppied. However, right clicking the point of entry in a LibreOffice Writer dcoumnet results in "paste" being greyed out and, if selected, displays "no paste options available." 

Using Control+C from the keyboard on highlighted docx text to place the information on the clipboard and right clicking on the mouse in LibreOffice Writer again results "paste" being greyed out and, if selected, displays "no paste options available." 

Using Control+C to copy highlighted text within the docx text followed by Control+Y at the selected point of entry in a Writer document will function properly a maximum of three times within Writer document. Additionally, selecting "edit" from the menue results in "Paste" being greyed out in the drop down menu.

I currently have two different computers, both with the same operating system, same version of Office 365 and, same version of Libre Office installed. The computers each have different 64-bit microprocessors and different memory configurations. However, both systems are experiencing the same issues.

FYI the cut and paste works flawlessly between docx and WordPerfect so it is not a clipboard incompatibility.

Open GL and Open CL are both functional.

Both computers are configured as follows
current Operating System is Windows 10 Pro x64 ver. 16.0.17134 Build 17134
Office 365 version is 16.0.11029.20108
LibreOffice version is 6.1.2.1
Memory on one system has an I3 processor and 4-GB memory the other has and I5 processor and 8-GB of memory.

If any additional information is needed, please state specifically what information you need.
Comment 4 Buovjaga 2019-08-16 08:13:10 UTC
Tested with this coreography (Win 10):
1. Copy from Word 365 to LibO, OK
2. Copy from Firefox to LibO, OK
3. Copy from Word 365 to LibO, OK
4. Copy from Notepad++ to LibO, OK
5. Copy from Word 365 to LibO, OK

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded

DoctorBob: could you try this daily build (installs separately): https://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/current/
The installer you want ends with "LibreOfficeDev_6.4.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_vec_qtz.msi"
Comment 5 Xisco Faulí 2019-09-20 10:55:30 UTC
(In reply to Buovjaga from comment #4)
> Tested with this coreography (Win 10):
> 1. Copy from Word 365 to LibO, OK
> 2. Copy from Firefox to LibO, OK
> 3. Copy from Word 365 to LibO, OK
> 4. Copy from Notepad++ to LibO, OK
> 5. Copy from Word 365 to LibO, OK
> 
> Version: 6.4.0.0.alpha0+ (x64)
> Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
> CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
> TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
> Locale: fi-FI (fi_FI); UI-Language: en-US
> Calc: threaded
> 
> DoctorBob: could you try this daily build (installs separately):
> https://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/current/
> The installer you want ends with
> "LibreOfficeDev_6.4.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_vec_qtz.msi"

Setting to NEEDINFO