Bug 117480 - Mailmerge crash when saving merged document ( only the first time the connection is done )
Summary: Mailmerge crash when saving merged document ( only the first time the connect...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
: 118728 123364 123906 (view as bug list)
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-05-07 14:46 UTC by Andrew Watson
Modified: 2019-05-14 10:30 UTC (History)
17 users (show)

See Also:
Crash report or crash signature:


Attachments
"ASR Full report template.odt" - Mailmerge template to use to provoke bug. (13.53 KB, application/vnd.oasis.opendocument.text)
2018-05-07 14:48 UTC, Andrew Watson
Details
"00 Consolidated ASR forms.ods" - sample data spreadsheet to use to provoke bug (11.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-05-07 14:49 UTC, Andrew Watson
Details
sample_db698a94 (12.11 KB, application/vnd.oasis.opendocument.text)
2019-04-23 13:51 UTC, Andrés Maldonado
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Watson 2018-05-07 14:46:55 UTC
Description:
When using the appended template document (ASR Full report template.odt) and data source spreadsheet (00 Consolidated ASR forms.ods), mailmerge reliably crashes when asked to save the merged document in a single file.

This is a regression - these files work OK in all tested LO versions up to and including 5.4.5.1, but fails in all LO tested versions including and after 6.0.1.1.

Steps to Reproduce:
1. Open attached document "ASR Full report template.odt".

2. Select Edit>Exchange Database...

3. Click Browse...

4. Select attached document "00 Consolidated ASR Forms.ods". Click "Open".

5. Under "Available Databases", click on triangle next to "00 Consolidated ASR forms". "Sheet1" appears under it. Select it.

6. Click "Define"

7. Select "File>Print".

8. Dialogie "Your document contains address database fields. Do you want to print a form letter?" appears. Click "Yes".

9. In the next dialogue box, Select "File" and "Save as single document" under "Output".

10. Click "OK".

11. In the next dialogue, enter "sample.odt" as name to save as. Click "Save".


Actual Results:  
LibreOffice crashes for LO 6.0.1.1 and all later versions tested, under both Mac OS and Linux.

Specific versions tested where crash observed:

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-GB (en.UTF-8); Calc: group

Version: 6.0.4.0.0+
Build ID: 1a96483c413c7fd61f896ccb879b39b65d42749c
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2018-03-30_06:36:19
Locale: en-GB (en_GB.UTF-8); Calc: group

Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group


Expected Results:
Mail-merged file "sample.odt" is saved. This is observed to work for LO 5.4.5.1 and all earlier versions tested, under both Mac OS and Linux.

Specific versions tested where the mail-merge works as expected:

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
(Works under Mac OS 10.11.6, even though LO complains that JRE is not installed).

Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)

Version: 5.2.7.2
Build ID: 1:5.2.7-0ubuntu1~xenial1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group

Version: 5.4.5.1
Build ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-GB (en.UTF-8); Calc: group



Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This mail-merge template is in production use in a real-world application under LO 5, generating reports for ODS spreadsheets containing 80+ rows.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Andrew Watson 2018-05-07 14:48:35 UTC
Created attachment 141958 [details]
"ASR Full report template.odt" - Mailmerge template to use to provoke bug.
Comment 2 Andrew Watson 2018-05-07 14:49:42 UTC
Created attachment 141959 [details]
"00 Consolidated ASR forms.ods" - sample data spreadsheet to use to provoke bug
Comment 3 Xisco Faulí 2018-05-07 16:00:45 UTC
Thanks for reporting the issue.
It looks like a dupe of bug 116543

*** This bug has been marked as a duplicate of bug 116543 ***
Comment 4 Telesto 2018-08-24 10:34:15 UTC
From bug 116543 comment 20
"Steps to reproduce" for Bug 117480 (which is currently marked as a
duplicate of Bug 116543) still triggers a crash in both:

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-GB (en.UTF-8); Calc: group threaded

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded

There's a crash report for the Linux version here:

crashreport.libreoffice.org/stats/crash_details/d64871ad-755a-4342-a105-4f215be61e1f

So it seems that Bug 117480 is a separate (still unfixed) bug, and not in fact
a duplicate of Bug 116543.

Setting back to unconfirmed (as nobody confirmed it yet).
Comment 5 marcoleli 2018-08-30 13:37:38 UTC
It happens on Windows, too. And not only for the files attached, but also for new test files I tried. 
The Mailmerge function seems completely unusable to me.


Versione: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Thread CPU: 4; SO: Windows 6.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT); Calc: group
Comment 6 Dieter Praas 2018-08-30 14:01:57 UTC
I change status to NEW because comment 5 confirms the bug.
Comment 7 Xisco Faulí 2018-09-03 10:18:10 UTC
(In reply to Dieter Praas from comment #6)
> I change status to NEW because comment 5 confirms the bug.

Indeed, reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 4b5fcd417587cfb9e6d8b61ecb037ab165eeb5b9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 8 Xisco Faulí 2018-09-03 10:26:07 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=97477ee5e11951a5a25a91b89f1b71a1b78ac8f5

author	Szymon Kłos <szymon.klos@collabora.com>	2017-09-08 10:57:55 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-09-09 11:42:50 +0200
commit	97477ee5e11951a5a25a91b89f1b71a1b78ac8f5 (patch)
tree	77d49f492b37bc05ac9eafc77b7a7f28c31530ed
parent	a45800f010f3e063c6f31426fcdba76aa5b43d3e (diff)
tdf#108572 remove connections only for current shell

Bisected with: bibisect-win32-6.0

Adding Cc: to Szymon Kłos

it seems the problem is only reproduced the first time we do the connection between the .odt file and the .ods file. After the first crash, it no longer crashes. Thus, the user folder needs to be removed every time
Comment 9 Xisco Faulí 2018-09-03 10:26:58 UTC
@Mike Kaganski, since you fixed bug 116543, I thought you could be interested in this issue, which is still reproducible in master...
Comment 10 Andrew Watson 2018-12-21 11:41:16 UTC
Tested with: LO 6.2RC1 - crash still occurs.

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-GB (en.UTF-8); UI-Language: en-US
Calc: threaded

Unfortunately this bug prevents me using LO 6 in my day-to-day work, so I have to stay with LO 5.
Comment 11 Commit Notification 2019-01-02 20:43:17 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/92edea090128839f54a7f628662529e66d657ab4%5E%21

tdf#117480 fix crash in mailmerge

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Szymon Kłos 2019-01-02 20:48:44 UTC
Current status: crash is fixed but result is not as expected (error occurs during printing) and output file is empty.
Comment 13 Xisco Faulí 2019-01-07 11:07:23 UTC
I do confirm the crash is no longer reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

but the output file is blank...
Comment 14 Xisco Faulí 2019-01-07 11:10:57 UTC
*** Bug 118728 has been marked as a duplicate of this bug. ***
Comment 15 Andrew Watson 2019-01-18 11:04:14 UTC
Tested with LO 6.2RC2 - crash still occurs.

Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-GB (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 16 Dieter Praas 2019-01-18 11:29:33 UTC
(In reply to Andrew Watson from comment #15)
> Tested with LO 6.2RC2 - crash still occurs.
> 
> Version: 6.2.0.2
> Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
> CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
> Locale: en-GB (en.UTF-8); UI-Language: en-US
> Calc: threaded

Andrew, actually it is only fixed in LO 6.3.0.0 (see comment 3). So you should try it with the actual master (parallel installation by default).
Comment 17 Xisco Faulí 2019-02-11 17:44:30 UTC
*** Bug 123364 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2019-04-10 11:43:17 UTC
*** Bug 123906 has been marked as a duplicate of this bug. ***
Comment 19 Andrés Maldonado 2019-04-23 13:50:13 UTC
This bug is no longer present on:

Version: 6.3.0.0.alpha0+
Build ID: db698a94ad52d1fbc387df66845907595615bb4f
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

The output file is no longer blank
(see sample_db698a94.odt)
Comment 20 Andrés Maldonado 2019-04-23 13:51:19 UTC
Created attachment 150951 [details]
sample_db698a94
Comment 21 Andrew Watson 2019-05-13 14:46:42 UTC
Confirming that the bug is no longer present in:

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

No crash, and the output file contains the expected text.

The real-world application from which the test files were derived also now works as expected.

Thanks for fixing this.
Comment 22 Dieter Praas 2019-05-13 15:02:52 UTC
RESOLVED FIXED because of comment 21
Comment 23 Xisco Faulí 2019-05-14 10:06:23 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 630db80d17616d635cf2e5f1d5a0852428b794a3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded