Bug 117538 - ODT empty pages at end of file
Summary: ODT empty pages at end of file
Status: RESOLVED DUPLICATE of bug 116872
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Page Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2018-05-10 07:45 UTC by Nikola
Modified: 2018-07-25 18:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (31.91 KB, application/vnd.oasis.opendocument.text)
2018-05-10 07:45 UTC, Nikola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola 2018-05-10 07:45:03 UTC
Description:
When file opened there are 60+ pages, do not understand why.

Steps to Reproduce:
1. Open attached file with defined LO version..
2.
3.

Actual Results:  
Lot of empty pages at end of file..

Expected Results:
There should be no empty pages at end of file..


Reproducible: Always


User Profile Reset: No



Additional Info:
Tried OO 4 and returns expected result.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Comment 1 Nikola 2018-05-10 07:45:41 UTC
Created attachment 142009 [details]
Example file
Comment 2 Nikola 2018-05-10 07:47:33 UTC
P.s. When exported to PDF no empty pages (!?)
Comment 3 Telesto 2018-05-10 12:30:03 UTC
Repro with
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL

but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 raal 2018-05-11 19:21:43 UTC
This seems to have begun at the below commit.
Adding Cc: to Jan-Marek Glogowski ; Could you possibly take a look at this one?
Thanks

a3b10f1ac4201a60e922a6c234c5bf6d3252337d is the first bad commit
commit a3b10f1ac4201a60e922a6c234c5bf6d3252337d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Jul 20 15:06:58 2017 +0200

    source sha:d7a2fd3e8262b8897ad06f01f25f46330e050e0c
author	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-18 19:55:01 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-20 10:27:19 +0200
commit	d7a2fd3e8262b8897ad06f01f25f46330e050e0c (patch)
tree	5f023adf59447fe933ff7c3cce7cf5b42f730c23
parent	8d4d1e8d1cd4b400bc395dcbb98fb1e82eaf4e0f (diff)
tdf#109123 Change SwDocIdle base class to Idle
Comment 5 Justin L 2018-07-24 18:13:40 UTC
Another example document is attachment 59581 [details] from bug 48378
Comment 6 Justin L 2018-07-25 18:48:47 UTC

*** This bug has been marked as a duplicate of bug 116872 ***