Bug 117543 - Copying/pasting a page doesn't include the master page content when pasting to a new document
Summary: Copying/pasting a page doesn't include the master page content when pasting t...
Status: RESOLVED DUPLICATE of bug 112697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2018-05-10 09:28 UTC by Telesto
Modified: 2018-06-21 14:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.84 KB, application/vnd.oasis.opendocument.graphics)
2018-06-20 21:03 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-10 09:28:30 UTC
Description:
Copying/pasting a page doesn't include the master page content when pasting to a new document

Steps to Reproduce:
1. Open the attached file
2. Copy the page
3. Paste it into a new Draw document

Actual Results:  
Only a yellow square gets pasted

Expected Results:
Wysiwyg


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2018-06-08 18:50:31 UTC
Attachment amnesia :)
Comment 2 Telesto 2018-06-20 21:03:12 UTC
Created attachment 142983 [details]
Example file

(In reply to Buovjaga from comment #1)
> Attachment amnesia :)

I should stick with descriptions instead of an example file
Comment 3 Buovjaga 2018-06-21 10:53:05 UTC
I don't even get a yellow square, simply nothing.

The weird thing is, I see the smiley face in the preview with "1" when I right-click the page pane.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 0929a98acca8ec4d86caa97d3090a39f89f35f90
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 20th 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Regina Henschel 2018-06-21 12:52:11 UTC
Rename the master page in the source document, so that it is different from any default and different from master page names in the target document. Then try again.

Pasting from clipboard has no auto-renaming for master pages.
Comment 5 Buovjaga 2018-06-21 13:24:16 UTC
Same as bug 112697?
Comment 6 Regina Henschel 2018-06-21 13:56:28 UTC
(In reply to Buovjaga from comment #5)
> Same as bug 112697?

I think, it is the same, at least it should be handled together.

A decision about the desired behavior in case of identical names is needed, e.g. (a) silent rename of source master page and add it as new master page (b) dialog about name conflict (c) silent apply of standard page object from source to target master page. The desired behavior is likely different for copy&paste inside a document compared to copy&paste between documents.
Pasting pages to and from Draw has the additional aspect, that source and target document might have different layer-sets.

I think, copy&paste of pages/slides between documents need some UX-advice.
Comment 7 Buovjaga 2018-06-21 14:52:40 UTC
I will summon UX to the older report and quote you.

*** This bug has been marked as a duplicate of bug 112697 ***