Bug 117546 - Crash when closing Calc
Summary: Crash when closing Calc
Status: RESOLVED DUPLICATE of bug 117228
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-10 10:09 UTC by Telesto
Modified: 2018-05-23 19:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-10 10:09:08 UTC
Description:
Crash when closing Calc (I suspect this to be a dupe of bug 117228 or bug 117545; however different BT)

Steps to Reproduce:
1. Open attachment 139120 [details] (bug 115034)
2. Copy column A1
3. Open a new calc document
4. Paste (A1)
5. Close the second document
6. Close the first document (red cross) -> Crash

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Roman Kuznetsov 2018-05-20 07:09:53 UTC
I don't confirm in to
Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group
Xubuntu 17.10 64-bit

only Windows problem?

but...Telesto, do you have question about macros enable when you open doc from attach 139120? What security options do you have?
Comment 2 geraldg 2018-05-20 09:19:59 UTC
Works fine in the linux-version 6.1 alpha 1
Comment 3 himajin100000 2018-05-20 12:16:00 UTC
reproducible.

typo: 
Copy column A1
=> Copy column A

Version: 6.1.0.0.alpha1+ (x64)
Build ID: e1a8338876bd161de4e9d9a4b22d4bc5335f7cee
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-05-18_23:55:37
Locale: ja-JP (ja_JP); Calc: CL
Comment 4 Telesto 2018-05-23 19:50:49 UTC

*** This bug has been marked as a duplicate of bug 117228 ***