Download it now!
Bug 117569 - EDITING Copy-pasting text with different level of indent discards hierarchy
Summary: EDITING Copy-pasting text with different level of indent discards hierarchy
Status: RESOLVED DUPLICATE of bug 128046
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError, regression
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2018-05-11 18:14 UTC by Aron Budea
Modified: 2020-01-17 17:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODP (11.76 KB, application/vnd.oasis.opendocument.presentation)
2018-05-11 18:14 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-05-11 18:14:45 UTC
Created attachment 142037 [details]
Sample ODP

- Open attached sample presentation.
- Select and copy the first two lines.
- Paste into the third line.

=> The second pasted line should be indented a level, but it isn't.

Observed using LO 6.0.3.2 / Ubuntu 17.10.
No issue with LO 5.4.0.3.
=> regression

Bibisected to the following commit using repo bibisect-linux-64-6.0. So this is rather an implementation error, and unfortunately Varun isn't active anymore.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e333183d4390da0b17a55f214e2b953dbb0a8883
author		Varun Dhall <varun.dhall@studentpartner.com>	2017-07-13 00:36:46 +0530
committer	Michael Stahl <mstahl@redhat.com>	2017-07-12 23:28:06 +0200

"EditEngine: Making ODF Format Default for Copy/Paste"

At this point the bullet is completely lost from the second line. Later this part is fixed, by the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a44e62b82c7598471da9a5254953067613806337
author		Eike Rathke <erack@redhat.com>	2018-03-02 20:31:48 +0100
committer	Eike Rathke <erack@redhat.com>	2018-03-02 20:32:41 +0100

"Resolves: tdf#114675 return new EditPaM of insert position from SvxReadXML()"
Comment 1 hardy 2019-08-12 11:15:00 UTC
This regression is still present in the current release of Impress in LibreOffice Version 6.3.0.4
Comment 2 Xisco Faulí 2020-01-17 17:55:27 UTC
https://gerrit.libreoffice.org/c/core/+/86983 fixes this. Closing as dupe of bug 128046

*** This bug has been marked as a duplicate of bug 128046 ***