Download it now!
Bug 117578 - impossible to open some files, reported as "non existent"
Summary: impossible to open some files, reported as "non existent"
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-12 12:02 UTC by fre.hmiss
Modified: 2018-05-12 12:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fre.hmiss 2018-05-12 12:02:31 UTC
Description:
yesterday the app crashed and did not open for a very long time. i had to switch on and off the device twice in order to make it work properly. however, since this morning, some of my most important files do not open when i click on the icon in the folder "recent files". the individual icons of the single files appear only among the recently opened documents, but is no longer among the saved ones.
I request immediate assistance as those files are crucial for upcoming exams and are impossible to re-write ex novo.

Steps to Reproduce:
1. click on the icon of a specific file that I've been writing on for months now
2. wait for the file to open with all of the last modifications where they should be


Actual Results:  
the file does not open,and after a few minutes a notice appears telling that 
"C:\Users\francesca\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe\LocalState\Files\S0\618\INGLESE PENTAMESTRE.odt non esiste.", which means, translated into english, that the file does not exist. 

Expected Results:
the file opens and I am able to go on writing without issues


Reproducible: Always


User Profile Reset: No



Additional Info:
the files i am not able to open without getting the above notice are the most recently opened ones, as i had been writing on them until yesterday morning. again, i insist to receive immediate help because those documents are considerably important and I have been wotking on them for months. moreover, i cannot pass the upcoming exams without them.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Julien Nabet 2018-05-12 12:27:18 UTC
You can try a Windows search of all odt files in C:\Users\francesca\AppData\Local\Packages

Then create a distinct directory, for example in "My Docs" and save your files here.
Indeed, the previous directory seems to be used for Windows apps like Outlook.

Also, check the available space on your hard disk just to be sure you've got enough room.
Comment 2 Mike Kaganski 2018-05-12 12:42:39 UTC
What you describe is not a bug, but user error. You seem to have worked with *temporary* files created by an external program (e.g., by double-clicking an attachment in a message, editing the opened file, and saving in-place). The place where that external application places its temporary files might be cleared by that application without notice. The crash you describe might well be caused by such cleanup happening when you worked with such temporary file (e.g., that app could erase a lockfile, which was not possible with 4.x and some 5.x versions).

You should have cared to save your important data to a place where it is safe (e.f., to My Documents folder). LibreOffice indeed keeps track of files which you have lately worked with (i.e., it remembers where they were), but if they are not there, it doesn't have in-built magic to make them appear.

I highly doubt that there's something you can do now with the absent files. Even file recovery utilities would be useless in case of a system disk (where all system IO takes place constantly), after you have rebooted the system several times.

Anyway, your issue is not a proper bug report/feature request, which are only on-topics on this site. Closing RESOLVED INVALID.