Bug 117599 - LibreOffice Viewer on my Tablet doesn't allways open writer documents (odt-type)
Summary: LibreOffice Viewer on my Tablet doesn't allways open writer documents (odt-type)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Android
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2018-05-13 12:11 UTC by post
Modified: 2020-03-09 15:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
odt-format, normal document, no specific characteristic (225.44 KB, application/vnd.oasis.opendocument.text)
2018-06-13 14:56 UTC, post
Details
screenshot with current master (167.72 KB, image/png)
2020-03-09 15:17 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description post 2018-05-13 12:11:37 UTC
Description:
I have a lot of odt-documents in my local space on my Huawei MediaPad M3 Lite 10 with Android 7.0, EMUI-Version 5.1. 
With the LibreOffice Viewer I can mostly open the writer-documents (.odt).
Sometimes the Viewer doesn't show the content of the document.
Up to now I could not determine any cause for that bug.
Thank you for your help. 

Steps to Reproduce:
1.Save odt document on yout tablet
2.Open the odt-document with the LibreOffice viewer
3.

Actual Results:  
1. Ok
2. Mostly ok, but not allways

Expected Results:
Don't know


Reproducible: Sometimes


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Xisco Faulí 2018-06-13 09:03:08 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 post 2018-06-13 14:56:24 UTC
Created attachment 142705 [details]
odt-format, normal document, no specific characteristic

For instance the attached file cannot be opened by LibreOffice Reader but by the OpenDocument Reader and by the Office Documents Reader.
Other documents of that type can be opened correctly by LibreOffice Reader.
Comment 3 post 2018-08-10 21:03:57 UTC
Is there any solution of the problem?
Comment 4 raal 2018-10-16 15:10:37 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: c8481c8; Android 5

I can open other documents, but not this one.
Comment 5 QA Administrators 2019-12-04 04:21:39 UTC Comment hidden (obsolete)
Comment 6 Michael Weghorn 2020-03-09 15:17:53 UTC
Created attachment 158517 [details]
screenshot with current master

Opening the attached document now works for me with a build from current git master (as of commit 0d81a613ef5af22253e51d9917c5d5c94d764456), s. attached screenshot.
Comment 7 Michael Weghorn 2020-03-09 15:18:39 UTC
(In reply to Michael Weghorn from comment #6)
> Created attachment 158517 [details]
> screenshot with current master
> 
> Opening the attached document now works for me with a build from current git
> master (as of commit 0d81a613ef5af22253e51d9917c5d5c94d764456), s. attached
> screenshot.

-> Closing as WORKSFORME, please reopen and leave a comment if you're still seeing the issue with a current daily build from [1].

[1] https://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/