Bug Hunting Session
Bug 117652 - Crash when inserting fontwork shape
Summary: Crash when inserting fontwork shape
Status: RESOLVED DUPLICATE of bug 116993
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2018-05-16 19:34 UTC by Regina Henschel
Modified: 2018-05-21 20:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Call stack as reported by Visual Studio (4.84 KB, text/plain)
2018-05-16 19:34 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-05-16 19:34:47 UTC
Created attachment 142135 [details]
Call stack as reported by Visual Studio

Start Impress with an empty slide.
Insert a Fontwork shape "Favorite 6".
Click outside the shape to deselect it. => crash.

I see this in Version: 6.1.0.0.alpha1+ (x64)
Build-ID: 88051c660fc6759346a01bc559818d3e23f8f55c
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL

Same in Draw does not crash.

It is OK in Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: CL
Comment 1 Jacques Guilleron 2018-05-17 12:22:16 UTC
Hi Regina,

I reproduce with
LO  6.1.0.0.alpha1+
Build ID: 8a2745e1beee722c8c9691c397e493cc1160bedf
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-30_23:24:36
Locale: fr-FR (fr_FR); Calc: CL
also with
LO 6.1.0.0.alpha0+
Build ID: f80029445e2b558f0d0e0a25c2c1bbcbe5254120
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-13_23:07:11
Locale: fr-FR (fr_FR); Calc: CL

but not with
LO  6.1.0.0.alpha0+ Build ID: dd4f1b1bd31daf080dc0420524712dc244e539b5
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-20_23:26:38
Locale: en-US (fr_FR); Calc: CL
Comment 2 raal 2018-05-21 20:11:18 UTC
no crash in Version: 6.1.0.0.alpha1+
Build ID: db608e8e5e27cce8eeda26918bcab71222d342df
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
and Version: 6.1.0.0.alpha1+ (x64)
Build ID: e1a8338876bd161de4e9d9a4b22d4bc5335f7cee
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-05-18_23:55:37

*** This bug has been marked as a duplicate of bug 116993 ***