Bug 117658 - equations appear twice in pptx import
Summary: equations appear twice in pptx import
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.4
Keywords: bibisected, bisected, regression
: 107697 124915 (view as bug list)
Depends on:
Blocks: Matters-to-Caolan PPTX
  Show dependency treegraph
 
Reported: 2018-05-17 07:43 UTC by john
Modified: 2019-12-07 20:38 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice screenshot (51.19 KB, image/png)
2018-05-17 07:45 UTC, john
Details
powerpoint screenshot (13.60 KB, image/png)
2018-05-17 07:46 UTC, john
Details
one slide, shows the problem when opened in libreoffice (205.28 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-05-17 07:49 UTC, john
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john 2018-05-17 07:43:44 UTC
Description:
When importing PPTX files into LibreOffice 5.4.6.2, I see equations appearing twice. One equation appears to be a bitmap, perhaps created by PowerPoint, and the other equation appears to be a poor attempt at mimicking that equation using the LO Formula Editor.

I suspect that this approach was implemented to reduce data loss when transferring from one format to another. But I didn't see any but report about this behaviour. With the attached images you can see it makes for a lot of work...

Steps to Reproduce:
1. open PPTX file containing equations
2. note duplicate formulae as per screenshot attached
3. file bug

Actual Results:  
As per libreoffce screenshot attached.

Expected Results:
As per powerpoint screenshot attached


Reproducible: Always


User Profile Reset: No



Additional Info:
In Writer, I believe that equations are left untouched by LibreOffice until the user requests to edit them. If editing them, they are converted to a form that can be edited. LO should preserve the Powerpoint appearance, and only create the local rendering in the (reversible/undoable) case where the user seeks to edit a particular equation.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 john 2018-05-17 07:45:05 UTC
Created attachment 142142 [details]
libreoffice screenshot
Comment 2 john 2018-05-17 07:46:49 UTC
Created attachment 142143 [details]
powerpoint screenshot
Comment 3 john 2018-05-17 07:49:04 UTC
Created attachment 142144 [details]
one slide, shows the problem when opened in libreoffice
Comment 4 Jacques Guilleron 2018-05-17 14:49:22 UTC
Hi John,
I reproduce with
LO 5.2.0.0.alpha1 Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR)
and upper versions
but not with
LO  5.1.6.2 Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 5 raal 2018-05-24 13:05:19 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one? Thanks

4e0cdc9abc7e396084596c0e5c3bc9c3a3945c14 is the first bad commit
commit 4e0cdc9abc7e396084596c0e5c3bc9c3a3945c14
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jan 22 04:45:41 2016 -0800

    source sha:332a796366b7cb91dff41de4b9ffb17843112a3e

author    Michael Stahl <mstahl@redhat.com>    2016-01-21 17:39:26 +0100
committer    Michael Stahl <mstahl@redhat.com>    2016-01-21 19:42:56 +0100
commit    332a796366b7cb91dff41de4b9ffb17843112a3e (patch)
tree    b578760ddfffde56cfe9e876b3e86a0916ad79a0
parent    a73e606b8cd714520285b4e40890db9fd27d7ba5 (diff)
oox: import Math objects from PPTX files
Comment 6 Regina Henschel 2018-07-01 22:39:21 UTC
*** Bug 107697 has been marked as a duplicate of this bug. ***
Comment 7 Amr Ibrahim 2018-11-08 18:33:51 UTC
Still reproducible in
Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.18.04.1
Comment 8 leo 2018-11-08 19:33:54 UTC
Still reproducible in Version: 6.1.3.2
Build-ID: 1:6.1.3~rc2-0ubuntu0.18.04.2

awful bug which hurts about every scientific presentation!
Comment 9 Oliver Sander 2019-04-09 07:46:18 UTC
Reproducable with

Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 john 2019-09-19 14:39:26 UTC
Still present in 6.2.6.2

Version: 6.2.6.2
Build ID: 1:6.2.6-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Commit Notification 2019-11-11 14:10:01 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b280c02d584ad403417db0e8840f8ae6de245883

Related: tdf#117658 PPTX import: ignore math text outside <m:t>

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-11-13 17:44:36 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4038d6c393c3cf6330671124ba69cdba98b24960

tdf#117658 PPTX import: fix duplicated math object handling

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-11-14 07:31:30 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/956153105bbf900f3b20aea98338148cf545fa0e

tdf#117658 PPTX import: fix duplicated math object handling

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Miklos Vajna 2019-11-14 07:48:41 UTC
I think this is now fixed on master.
Comment 15 Xisco Faulí 2019-11-14 10:42:28 UTC
Verified in

Version: 6.4.0.0.beta1+
Build ID: 956153105bbf900f3b20aea98338148cf545fa0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!
Comment 16 Commit Notification 2019-11-15 07:42:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1ae07c3555721cd07a24ace4c20c24f04d73f153

Related: tdf#117658 PPTX import: ignore math text outside <m:t>

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-11-16 09:36:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/c9efa80d4d71aacb57a81c4fd1da163aee9f3966

tdf#117658 PPTX import: fix duplicated math object handling

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Timur 2019-12-07 20:38:24 UTC
*** Bug 124915 has been marked as a duplicate of this bug. ***