Bug Hunting Session
Bug 117719 - add labels Minimum and Maximum for drop-down lists in dialogue Conditional Formatting
Summary: add labels Minimum and Maximum for drop-down lists in dialogue Conditional Fo...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Conditional-Formatting-Editing
  Show dependency treegraph
 
Reported: 2018-05-21 07:33 UTC by Roman Kuznetsov
Modified: 2018-11-13 18:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with problem and offering (51.63 KB, image/png)
2018-05-21 07:36 UTC, Roman Kuznetsov
Details
Right mockup for this bug (26.34 KB, image/png)
2018-05-21 19:12 UTC, Roman Kuznetsov
Details
Mockup for All cells - Color scale (3 entries) (29.53 KB, image/png)
2018-05-21 20:07 UTC, Roman Kuznetsov
Details
Labels in MS Excel (12.73 KB, image/png)
2018-05-21 20:08 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-05-21 07:33:46 UTC
Description:
add labels Minimum and Maximum to drop-down lists in dialogue Conditional Formatting, for variant 
All cell - Color Scale (2 entries)
All cell - Color Scale (3 entries)
All cell - Data bar

Steps to Reproduce:
1. Open Calc
2. Open dialogue Conditional Formatting
3. Select variant Any cell - Color Scale (2 entries) (or Color Scale (3 entries) or Data bar)
4. Look at two drop-down lists to left and to right. It are types of Minimum and Maximum values
5. But user don't know this, because there aren't any labels by those lists

I offer add labels to user know, that select from drop-down lists.

Actual Results:  
drop-down lists for selecting Min and Max values don't have any labels

Expected Results:
drop-down lists for selecting Min and Max values have labels Minimum and Maximum


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Comment 1 Roman Kuznetsov 2018-05-21 07:36:48 UTC
Created attachment 142222 [details]
Screenshot with problem and offering
Comment 2 Heiko Tietze 2018-05-21 17:50:09 UTC
You get what you want with "top n elements = 1" and bottom respectively given that the other patch is implemented. We should not overload the lengthy menu, so my take is WFN.
Comment 3 Mike Kaganski 2018-05-21 18:22:01 UTC
(In reply to Heiko Tietze from comment #2)
> You get what you want with "top n elements = 1" and bottom respectively
> given that the other patch is implemented. We should not overload the
> lengthy menu, so my take is WFN.

I am sorry: IIUC, OP doesn't suggest adding something to the drop-down menu: his proposal is to add labels next to drop-downs that would say something like (referring to the screenshot he provided):

"Min: [Automatic ][V]             Max: [Automatic][V]"
Comment 4 Roman Kuznetsov 2018-05-21 19:12:28 UTC
Created attachment 142231 [details]
Right mockup for this bug
Comment 5 Roman Kuznetsov 2018-05-21 19:14:17 UTC
(In reply to Heiko Tietze from comment #2)
> You get what you want with "top n elements = 1" and bottom respectively
> given that the other patch is implemented. We should not overload the
> lengthy menu, so my take is WFN.

Heiko, it was my mistake. I made screenshot with not correct my comments =(
I attached new mockup with correct view
Comment 6 Roman Kuznetsov 2018-05-21 20:07:08 UTC
Created attachment 142232 [details]
Mockup for All cells - Color scale (3 entries)
Comment 7 Roman Kuznetsov 2018-05-21 20:08:18 UTC
Created attachment 142233 [details]
Labels in MS Excel
Comment 8 Heiko Tietze 2018-05-22 09:01:31 UTC
Okay, got it. But minimum/maximum is misleading since min/max are an option in the dropdown like percentile, value... How about "Lower/Upper threshold"?
Comment 9 Roman Kuznetsov 2018-05-22 10:31:58 UTC
(In reply to Heiko Tietze from comment #8)
> Okay, got it. But minimum/maximum is misleading since min/max are an option
> in the dropdown like percentile, value... How about "Lower/Upper threshold"?

may be we'll follow Excel in this case?
Comment 10 Heiko Tietze 2018-05-27 08:54:28 UTC
(In reply to kompilainenn from comment #9)
> may be we'll follow Excel in this case?

Sure, we can do. But we would have to rename "Min" and "Max" because "Minimum = Min" sounds weird. MSO calls it "Lowest value".
The alternative was to label the option not as "Minimum" but "Lower threshold" (or boundary) and keep "Min". Both work, the MSO approach sounds more professional.
Comment 11 Roman Kuznetsov 2018-05-27 09:06:08 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to kompilainenn from comment #9)
> > may be we'll follow Excel in this case?
> 
> Sure, we can do. But we would have to rename "Min" and "Max" because
> "Minimum = Min" sounds weird. MSO calls it "Lowest value".
> The alternative was to label the option not as "Minimum" but "Lower
> threshold" (or boundary) and keep "Min". Both work, the MSO approach sounds
> more professional.

Heiko, i think that we don't understand each other.
My bug about add LABEL above drop-down list, as NAME for this list.
You say about change item INSIDE drop-down list.
Comment 12 Commit Notification 2018-11-10 08:40:26 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b907fe59a819aaba75518dc1534eb71d9e378b74%5E%21

tdf#117719: add Minimum and Maximum labels to color bar CF

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 BogdanB 2018-11-13 18:26:11 UTC
Fixed. Verified on
Version: 6.2.0.0.alpha1+
Build ID: 7eb71f84db2f2d9a6e79a42d25bb676cf1018a90
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-12_17:12:50
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded