Bug 117750 - Some of the image filters aren't working (like Aging or Relief)
Summary: Some of the image filters aren't working (like Aging or Relief)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.2.0 target:7.1.3 target:7.0.6
Keywords: bibisected, bisected, regression
: 141602 (view as bug list)
Depends on:
Blocks: Images
  Show dependency treegraph
 
Reported: 2018-05-22 19:53 UTC by Telesto
Modified: 2021-04-13 18:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-22 19:53:47 UTC
Description:
Some of the image filters aren't working (like Aging or Relief)

Steps to Reproduce:
1. Some random image (like: https://wiki.documentfoundation.org/images/9/94/BHS_6.1.0_beta1_large.png)
2. Insert it into Writer or Draw
3. Select the image
4. Format -> Image -> Filter -> Select Aging or Relief (both have no effect)

Actual Results:  
Some of the filters aren't working

Expected Results:
All filters should work


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1+
Build ID: b9ebabd675f916a0151ec3893a59131f3a8b2a05
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-21_23:26:04
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.4.0.0.alpha0+
Build ID: e5c6d5ad35faa160bbd3daa593aac0782cd9f1ba
CPU threads: 4; OS: Windows 6.29; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Regina Henschel 2018-05-22 21:48:39 UTC
It works in Version: 6.1.0.0.alpha0+ (x64)
Build ID: 55b9706bea5aa9b654ab39bc7d56339422e17087
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-18_06:02:46
Locale: de-DE (de_DE); Calc: CL

It is broken in Version: 6.1.0.0.alpha1+ (x64)
Build ID: ea33ae5ef0a9d6b03fdef6503066100d0ae12729
CPU threads: 8; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2018-05-03_14:09:58
Locale: de-DE (de_DE); Calc: CL
Comment 2 raal 2018-05-24 13:02:23 UTC
Tested for Aging filter. This seems to have begun at the below commit.
Adding Cc: to Chris Sherlock ; Could you possibly take a look at this one? Thanks
 ba807aa54d3c27bc5c56d30b07691d2d687017d3 is the first bad commit
commit ba807aa54d3c27bc5c56d30b07691d2d687017d3
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Apr 21 22:12:07 2018 -0700

    source sha:1ab12471f3a69c4d502e6271e84ddf8a981f507f
author    Chris Sherlock <chris.sherlock79@gmail.com>    2018-04-20 20:32:23 +1000
committer    Tomaž Vajngerl <quikee@gmail.com>    2018-04-22 05:33:39 +0200
commit    1ab12471f3a69c4d502e6271e84ddf8a981f507f (patch)
tree    6652276229ad1c3ffca48f7a31e1b77d2ea04b07
parent    c38485279cd36da96ac81107d567ea4e779b2b96 (diff)
vcl: ImplSepia -> BitmapSepiaFilter
Comment 3 QA Administrators 2019-07-30 03:14:28 UTC Comment hidden (obsolete)
Comment 4 Regina Henschel 2019-07-30 21:54:04 UTC
The filters "Smooth", "Solarize" and "Sepia" do not work in Version: 6.4.0.0.alpha0+ (x64)
Build ID: 9105b85c708f42024ce063b9a944466c0afdfe9a
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-28_22:42:37
Locale: de-DE (en_US); UI-Language: en-US
Calc: CL
Comment 5 PeeWee 2020-04-25 08:39:52 UTC
Smooth filter definitely not working in LO Draw version 6.4.3
Comment 6 Petro Ding 2020-12-30 07:23:49 UTC
"Smooth", "Solarization" and "Aging" are still not working in 7.0.4.
Comment 7 Justin L 2021-01-26 15:03:06 UTC
repro 7.2+
@Chris Sherlock - no response at all?
Comment 8 Julien Nabet 2021-04-10 15:21:36 UTC
*** Bug 141602 has been marked as a duplicate of this bug. ***
Comment 9 PeeWee 2021-04-10 15:26:44 UTC
This bug has not been fixed. LO 7.1.1.2 in all operating systems still has the problem
Comment 10 Julien Nabet 2021-04-10 17:14:03 UTC
I submitted a patch for Sepia (Aging) and Solarization here:
https://gerrit.libreoffice.org/c/core/+/113926
Comment 11 Commit Notification 2021-04-10 18:23:57 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3d32e6a6ccfae56f379cb1dec6dcadf9aa8fa85f

Related tdf#117750: fix UnsharpenFilter

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-04-10 18:25:08 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f3151e62bcc7cb66313df70a2ec8eed8ca8f2c88

Related tdf#117750: fix "Solarization" and "Aging"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-04-11 10:14:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8a75c591ef0cb017c58a7f068d1ae6571f87bd90

Related tdf#117750: fix UnsharpenFilter

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-04-11 10:15:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/d41693f2eb48fce3d808f1719bbd60f2d2041203

Related tdf#117750: fix "Solarization" and "Aging"

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-04-12 12:05:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/cec82db4e6fbc0fd7ea1fa032461baaf327b0b16

Related tdf#117750: fix UnsharpenFilter

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-04-12 12:05:34 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/923db64220c69e819a58e0c256ac83bd3df1946a

Related tdf#117750: fix "Solarization" and "Aging"

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Julien Nabet 2021-04-13 18:50:30 UTC
UnsharpenFilter isn't fixed since it's activated only if radius is negative and UI doesn't allow this.
Following Tomaž's comment, I abandoned the patch since it seems not the right way.
Let's put this one to FIXED then.

If there are all other filter which don't work, don't hesitate to reopen this bugtracker.