Download it now!
Bug 117760 - Goal Seek failed
Summary: Goal Seek failed
Status: RESOLVED DUPLICATE of bug 68034
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-23 13:39 UTC by Paul Abraham
Modified: 2018-06-18 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal spreadsheet exhibiting fault (7.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-05-23 13:42 UTC, Paul Abraham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Abraham 2018-05-23 13:39:36 UTC
Description:
In the attached, very simple, spreadsheet, goal seek fails to find a solution.The formula cell is C1 and variable cell is B1. As far as I can tell the values used make no difference but as an example with A1 set to 10 and the target value also set to 10 B1 should be 1 - I can do that one in my head ;-).

Calc says "Goal Seek failed. Insert the closest value (0) into the variable cell anyway?"

Steps to Reproduce:
1. Use Goal Seek with the following data:
    Formula Cell: C1
    Target Value: 10
    Variable Cell: B1

Actual Results:  
Calc says "Goal Seek failed. Insert the closest value (0) into the variable cell anyway?"

Expected Results:
Value 1 entered in B1


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial3
CPU Threads: 2; OS Version: Linux 4.8; UI Render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.139 Chrome/66.0.3359.139 Safari/537.36
Comment 1 Paul Abraham 2018-05-23 13:42:05 UTC
Created attachment 142249 [details]
Minimal spreadsheet exhibiting fault
Comment 2 Paul Abraham 2018-05-23 13:49:04 UTC
A bit more exploring suggests that if there is already some value in B1 then it works. Looks like an initialisation problem.
Comment 3 Buovjaga 2018-06-18 07:01:46 UTC
It still succeeds in 3.5.0, but already fails in 3.6.7.

I found an existing report from Calc developer Eike.

Win 10
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: dc9ee533dc707cc10b99d537eaccc3ee5aa555fe
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 16th 2018

*** This bug has been marked as a duplicate of bug 68034 ***
Comment 4 Paul Abraham 2018-06-18 14:19:26 UTC
Worth noting, mind, that that report is five years old.