Download it now!
Bug 117766 - Macros Digital Signatures menu option missing in main window
Summary: Macros Digital Signatures menu option missing in main window
Status: RESOLVED DUPLICATE of bug 97694
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-23 19:02 UTC by Drew Jensen
Modified: 2018-05-30 02:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test odb with macro library (4.78 KB, application/vnd.oasis.opendocument.database)
2018-05-23 19:03 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-05-23 19:02:13 UTC
Description:
The menu item Tools - Macros - Digital Signature is missing from the main Base window, not allowing anyway to sign an embedded macro library.

Steps to Reproduce:
1. download and open the attached odb file (includes basic library)
2. select menu item Tools - Macros


Actual Results:  
 - Digital Signature option is not available.

Expected Results:
 - Digital Signature is available, disabled if no embedded library in file, enabled when this test file, library present, is open.


Reproducible: Always


User Profile Reset: No



Additional Info:
test system, Ubuntu 18.04 64bit, build:
Version: 6.1.0.0.alpha1+
Build ID: 6e7e4d9f02f286ccb817cb2c1f54a951dcebffad
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-05-21_01:55:12
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.139 Chrome/66.0.3359.139 Safari/537.36
Comment 1 Drew Jensen 2018-05-23 19:03:19 UTC
Created attachment 142256 [details]
test odb with macro library
Comment 2 Drew Jensen 2018-05-23 19:08:24 UTC
I see it isn't available in 6.0 either and I didn't go backwards because I assume it isn't there.

So, change this to a enhancement if that fits better. 

I would make the case that this feature is useful for ODB files.
Comment 3 Robert Großkopf 2018-05-24 17:15:43 UTC
Seems is had never been available in LO for Base. Have looked back to LO 3.6.7.2 - available in Writer, not available in Base ...

Tested with OpenSUSE 42.3 64bit rpm Linux.

I will set the version to LO 3.6.7.2
Comment 4 Drew Jensen 2018-05-30 02:35:32 UTC

*** This bug has been marked as a duplicate of bug 97694 ***