Download it now!
Bug 117814 - PIVOTTABLE: date format from registered data source lost (FORMATTING)
Summary: PIVOTTABLE: date format from registered data source lost (FORMATTING)
Status: RESOLVED DUPLICATE of bug 83720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Pivot-Table
  Show dependency treegraph
 
Reported: 2018-05-26 09:21 UTC by Oliver Brinzing
Modified: 2018-07-25 08:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
pivot table showing the date format problem (237.41 KB, image/jpeg)
2018-05-26 09:21 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Brinzing 2018-05-26 09:21:04 UTC
Created attachment 142289 [details]
pivot table showing the date format problem

steps to reproduce:

- use demo *.csv/*.odb data file from:
  "Bug 117813] *.csv database:changing character set needs a disconnect"
  https://bugs.documentfoundation.org/show_bug.cgi?id=117813

- create a pivot table as shown in attached picture
  -> the date format is lost, the date is displayed as a serial number
Comment 1 Buovjaga 2018-06-19 15:19:40 UTC
(In reply to Oliver Brinzing from comment #0)
> Created attachment 142289 [details]
> pivot table showing the date format problem
> 
> steps to reproduce:
> 
> - use demo *.csv/*.odb data file from:
>   "Bug 117813] *.csv database:changing character set needs a disconnect"
>   https://bugs.documentfoundation.org/show_bug.cgi?id=117813

How?

> - create a pivot table as shown in attached picture
>   -> the date format is lost, the date is displayed as a serial number

How?

We need steps.
Comment 2 Oliver Brinzing 2018-06-19 18:01:37 UTC
- download data.odb and data.csv from
  https://bugs.documentfoundation.org/show_bug.cgi?id=117813

- Tools/Options.../LibreOffice Base/Databases [New...], [Browse...], 
  select "data.odb" [OK]

- calc menu Data/Pivot Table/Create... 
  (*) Data Source registered in LibreOffice [OK]

- Database   [data ]
  Type       [Table]
  Data Souce [data ] [OK]

- add [Datum] to "Column Fields"
  [OK]
Comment 3 Buovjaga 2018-06-19 18:51:40 UTC
Thanks! I could repro, but not in 3.6.7 -> regression.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: dc9ee533dc707cc10b99d537eaccc3ee5aa555fe
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 16th 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Buovjaga 2018-06-20 15:07:56 UTC
Already in 4.4.7 (Win 10). I tried in 4.3.0, but it crashed when I was trying to create the pivot table!
Comment 5 Buovjaga 2018-07-11 15:58:00 UTC
With Linux 44max repo, oldest and latest commit crash on pivot table "Ok". Tried stepping 500 commits backwards from latest and it crashed as well.
Comment 6 Julien Nabet 2018-07-25 08:08:32 UTC

*** This bug has been marked as a duplicate of bug 83720 ***