Download it now!
Bug 117934 - Menus contain char artifacts in arabic (gtk2/gtk3)
Summary: Menus contain char artifacts in arabic (gtk2/gtk3)
Status: RESOLVED DUPLICATE of bug 73494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-31 13:56 UTC by Xisco Faulí
Modified: 2018-10-19 00:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
HTML compatibility (57.57 KB, image/png)
2018-05-31 13:56 UTC, Xisco Faulí
Details
VBA Properties (56.75 KB, image/png)
2018-05-31 13:57 UTC, Xisco Faulí
Details
Same problem in about dialog (44.42 KB, image/png)
2018-10-18 14:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-05-31 13:56:42 UTC
Created attachment 142443 [details]
HTML compatibility

Steps to reproduce:
1. Change LibreOffice to Arabic
2. Go to Tools - Options - Load/Save - VBA Properties or HTML Compatibility

-> Some characters contain empty squares. See attached pictures.

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: a7865cf710b71aa27b185f9d38c930f5603d37e7
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-05-31 13:57:12 UTC
Created attachment 142444 [details]
VBA Properties
Comment 2 Xisco Faulí 2018-05-31 14:07:11 UTC
Not reproduced with gen...
Comment 3 Xisco Faulí 2018-05-31 14:12:18 UTC
Also reproduced in

إصدارة: 6.0.4.2
معرّف البناء: 1:6.0.4~rc2-0ubuntu0.16.04.1
خيوط المعالج: 4; نظام التَّشغيل: Linux 4.13; مصيّر الواجهة: المبدئيّ; VCL: gtk3; 
المحليّة: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2018-05-31 14:29:18 UTC
Also reproduced in

إصدارة: 5.4.7.2
معرّف البناء: c838ef25c16710f8838b1faec480ebba495259d0
خيوط المعالج: 4; نظام التَّشغيل: Linux 4.13; مصيّر الواجهة: المبدئيّ; الواجهة: gtk2; 
المحليّة: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Xisco Faulí 2018-05-31 14:29:59 UTC
@Khaled, @Caolán, I thought you could be interested in this issue...
Comment 6 Khaled Hosny 2018-07-03 00:03:27 UTC
What is your default UI font? Does it happen to not support Arabic? Might be another manifestation of bug 73494.
Comment 7 Xisco Faulí 2018-10-18 14:56:33 UTC
Still reproducible in

إصدارة: 6.1.3.1
معرّف البناء: 1:6.1.3~rc1-0ubuntu0.16.04.1
خيوط المعالج: 4; نظام التَّشغيل: Linux 4.15; مصيّر الواجهة: المبدئيّ; VCL: gtk3; 
المحليّة: en-US (ca_ES.UTF-8); Calc: group threaded

The font is Noto Sans Regular.
Comment 8 Xisco Faulí 2018-10-18 14:57:07 UTC
Created attachment 145805 [details]
Same problem in about dialog
Comment 9 Khaled Hosny 2018-10-19 00:40:50 UTC
Noto Sans does not have Arabic characters, so that is a duplicate of bug 73494.

*** This bug has been marked as a duplicate of bug 73494 ***