Bug Hunting Session
Bug 117950 - Text boundaries disappear when entering text (gtk2)
Summary: Text boundaries disappear when entering text (gtk2)
Status: RESOLVED DUPLICATE of bug 101798
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-06-01 08:43 UTC by Ludwig Meier
Modified: 2018-06-01 10:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Step 1. (84.80 KB, image/png)
2018-06-01 08:44 UTC, Ludwig Meier
Details
After step 4. (86.39 KB, image/png)
2018-06-01 08:45 UTC, Ludwig Meier
Details
Step 6, boundaries diasappered. (88.61 KB, image/png)
2018-06-01 08:45 UTC, Ludwig Meier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ludwig Meier 2018-06-01 08:43:37 UTC
Description:
Text boundaries will be shown intermittently or disappear when entering text.

Steps to Reproduce:
1. Open LibreOffice Writer in safe mode.
2. Enable "View" → "Text Boundaries".
3. Enable "View" → "Formatting Marks".
4. Enter some text.
5. Enter a blank line.
6. Enter some more text.

Actual Results:  
Text boundaries will be shown intermittently or disappear. The problem has been discussed occasionally (e.g. https://ask.libreoffice.org/en/question/100732/text-boundaries-appear-intermittently/). Checking or unchecking hardware acceleration makes no difference.

Works fine in 6.0.4.2.

Expected Results:
Text boundaries visible.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.0.0.beta1
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Ludwig Meier 2018-06-01 08:44:34 UTC
Created attachment 142469 [details]
Step 1.
Comment 2 Ludwig Meier 2018-06-01 08:45:11 UTC
Created attachment 142470 [details]
After step 4.
Comment 3 Ludwig Meier 2018-06-01 08:45:39 UTC
Created attachment 142471 [details]
Step 6, boundaries diasappered.
Comment 4 Xisco Faulí 2018-06-01 10:35:08 UTC
Reproduced in

Version: 6.1.0.0.beta1+
Build ID: 2a0d8106a558845357d39648656e08ec6f091cf8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

but not in

Version: 6.1.0.0.beta1+
Build ID: 2a0d8106a558845357d39648656e08ec6f091cf8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

thus, gtk2 only...
Comment 5 Xisco Faulí 2018-06-01 10:38:49 UTC
This is an older regression. The reason why you don't reproduce it in 6.0.4.2 is because you're using GTK3 there... you should reproduce it if you use SAL_USE_VCLPLUGIN=gtk soffice...
Comment 6 Xisco Faulí 2018-06-01 10:42:21 UTC
Regression introduced by cb382034b061b4acd4f0fd490f42af34517a7b8d, which is the same commit as in bug 101798.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 101798 ***