Bug 117966 - Garbled text during slideshow with OpenGL enabled
Summary: Garbled text during slideshow with OpenGL enabled
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 118265 (view as bug list)
Depends on:
Blocks: VCL-OpenGL Slide-Show CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-06-01 22:54 UTC by Aron Budea
Modified: 2018-07-12 10:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODP (11.01 KB, application/vnd.oasis.opendocument.presentation)
2018-06-01 22:54 UTC, Aron Budea
Details
Screenshot (11.11 KB, image/png)
2018-06-01 22:55 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-06-01 22:54:09 UTC
Created attachment 142483 [details]
Sample ODP

With OpenGL rendering enabled, open the attached presentation, and watch the slideshow.

=> The bottom line is garbled (see screenshot).

Don't mind the missing middle line, that's bug 102195.

Observed using LO 6.1 beta1 / Windows 7.
No issue with LO 6.0.4.2.
=> regression

Bibisected to the following commit using repo bibisect-win32-6.1. Adding Cc: to Jan-Marek Glogowski, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=bdccb7e9991d83029eb2f2f11327b54534a00db8
author		Jan-Marek Glogowski <glogow@fbihome.de>	2017-12-26 15:14:31 +0000
committer	Khaled Hosny <khaledhosny@eglug.org>	2018-05-08 00:55:27 +0200

Refactor CommonSalLayout font handling
Comment 1 Aron Budea 2018-06-01 22:55:40 UTC
Created attachment 142484 [details]
Screenshot
Comment 2 Aron Budea 2018-06-25 20:55:36 UTC
*** Bug 118265 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2018-07-11 20:51:57 UTC
Should be fixed, animation of text lines in sample presentation appear correctly.

Retest with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 86ca9badf9be518be3456afde70271bc1f956065
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-11_02:27:04
Locale: en-US (en_US); Calc: CL

or later

=-ref-=

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fad862e290d727fc9fefe206f6e4b807482c4175

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ca4e75d694a5fb41a1c800146319aa6ba34d8bab