Download it now!
Bug 117969 - Light Magenta and Dark Magenta don't have Key ID in standard color palette .
Summary: Light Magenta and Dark Magenta don't have Key ID in standard color palette .
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
: 112993 (view as bug list)
Depends on:
Blocks: Color-Palettes
  Show dependency treegraph
 
Reported: 2018-06-02 00:16 UTC by Junichi Matsukawa
Modified: 2020-11-18 12:37 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Light Magenta don't have Key ID in standard color palette . (35.23 KB, image/png)
2018-06-02 00:22 UTC, Junichi Matsukawa
Details
Dark Magenta don't have Key ID in standard color palette . (35.36 KB, image/png)
2018-06-02 00:23 UTC, Junichi Matsukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Junichi Matsukawa 2018-06-02 00:16:40 UTC
Description:
I tried to translate the standard palette.
Light Magenta and Dark Magenta don't have Key ID  in standard color palette .

Steps to Reproduce:
1.Language is Key ID.
2.Open standard palette in LibreOffice.
3.Move the cursor over the Light Magenta or Dark Magenta.
4.The color name pops up.

バージョン: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS:Windows 10.0; UI render: GL; 
ロケール: ja-JP (ja_JP); Calc: CL

Actual Results:  
Light Magenta and Dark Magenta don't have Key ID  in standard color palette .

Expected Results:
The colors should be given a Key ID.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Comment 1 Junichi Matsukawa 2018-06-02 00:22:08 UTC
Created attachment 142485 [details]
Light Magenta don't have Key ID in standard color palette .
Comment 2 Junichi Matsukawa 2018-06-02 00:23:09 UTC
Created attachment 142486 [details]
Dark Magenta don't have Key ID in standard color palette .
Comment 3 Julien Nabet 2018-06-02 07:31:55 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.

Sophie/Jean-Baptiste: thought you might be interested in this one.
Comment 4 Julien Nabet 2018-06-02 07:47:30 UTC
Heiko: I think, given https://cgit.freedesktop.org/libreoffice/core/commit/?id=bbde6eeae5c0ca5e106eec53dc7882361897a616 which added Light magenta/Dark magenta, we should update include/svx/strings.hrc and perhaps svx/source/unodraw/unoprov.cxx, any thoughts?
Comment 5 Heiko Tietze 2018-06-02 08:19:44 UTC
Yes, please. The localization was introduced by Gabor in https://gerrit.libreoffice.org/#/c/49704/ but we changed the palette later once again.
Comment 6 Julien Nabet 2018-06-02 11:04:41 UTC
I submitted this patch on gerrit:
https://gerrit.libreoffice.org/#/c/55204/
Comment 7 Julien Nabet 2018-06-02 22:57:17 UTC
Abandoning patch https://gerrit.libreoffice.org/#/c/55204/ (for more details, see my last comment on it)
Comment 8 Gabor Kelemen 2018-06-03 13:53:30 UTC
I'm looking at it.
Comment 9 Commit Notification 2018-06-04 09:46:26 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56674b45cccd2702fe2bf40398c0bd00741040e1

tdf#117969: Translate Light/Dark Magenta

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-06-04 11:32:37 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20e211bc420d8f8afd02d6ef6fdbafeb2d5420b3&h=libreoffice-6-1

tdf#117969: Translate Light/Dark Magenta

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Junichi Matsukawa 2018-06-20 07:19:41 UTC
Hi. Everyone.

I confirmed the FIXED on 6.1.0.0.beta2 (x64).
Thakyou very much! arigatou.
Comment 12 Buovjaga 2020-11-18 12:37:57 UTC
*** Bug 112993 has been marked as a duplicate of this bug. ***