Bug 118060 - Selected cells always displays the result for the first selection in Calc.
Summary: Selected cells always displays the result for the first selection in Calc.
Status: RESOLVED DUPLICATE of bug 116208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-07 22:43 UTC by c.r.brownlie
Modified: 2018-06-10 11:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example screenshot of bug 118060 (12.05 KB, image/png)
2018-06-07 22:52 UTC, c.r.brownlie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description c.r.brownlie 2018-06-07 22:43:11 UTC
Description:
When the user selects several cells, there is a UI text on the bottom edge of the screen (second from left) which displays the number of rows and columns currently selected.


Observed Behaviour:

For example:
User selects 2x7 cells, display says "2 Rows, 7 columns selected".
User de-selects cells.
User selects 5x2 cells, display says "2 Rows, 7 columns selected".
User de-selects cells.
User selects 50x267 cells, display says "2 Rows, 7 columns selected".
etc

Steps to Reproduce:
1. Open Calc. Start new spreadsheet.
2. With mouse, click and drag to select several cells. Observe correct UI output.
3. With mouse, click and drag to select several different cells. Observe incorrect UI output, result as for first selection.

Actual Results:  
This field correctly shows the current number of selected cells and rows the first time some calls are selected.
For all subsequent multiple cell selections, the display does not update. It always shows the result for the first selection.


Expected Results:
This field should update to show the current number of selected cells and rows. When a new set of cells is selected, this UI info should update correctly.



Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.79 Safari/537.36
Comment 1 c.r.brownlie 2018-06-07 22:52:21 UTC
Created attachment 142602 [details]
Example screenshot of bug 118060
Comment 2 Jean-Baptiste Faure 2018-06-10 11:16:13 UTC
data in status bar are not updated: bug 116208.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 116208 ***