Bug Hunting Session
Bug 118067 - EDITING - Changing motion path animation from one type to another doesn't work
Summary: EDITING - Changing motion path animation from one type to another doesn't work
Status: RESOLVED DUPLICATE of bug 33022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-08 10:46 UTC by Afief Halumi
Modified: 2018-07-18 14:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Afief Halumi 2018-06-08 10:46:38 UTC
Add animation to object
Select type=motion path
Select animation=Right
Change your mind and select animation=arc down

Expected behavior: Right motion path disappears and arc down appears.
Actual result: Right motion path is still there and doesn't seem affected by selection.
Comment 1 Julien Nabet 2018-06-08 20:52:48 UTC
On pc Debian x86-64 with LO Debian package 6.0.5.1, I don't reproduce this.

On which env are you?
For the test, could you give a try to last stable LO version 6.0.4?
Comment 2 Afief Halumi 2018-06-09 06:07:14 UTC
Hi Julien,

Environment is KDE on Kubuntu 18.04.
Tested with the LibreOffice-6.0.4-x86_64.AppImage, still happens.
Note that the animation does change to Arc Down, but the motion path that is drawn on the slide doesn't reflect this (i.e. straight line to the right instead of an arc)

Screenshot: https://imgur.com/a/aLjkawT
Comment 3 Julien Nabet 2018-06-09 16:31:53 UTC
Thank you for the explanation.
Indeed, the motion path displayed on the slide doesn't change.
Let's put this to NEW then.
Comment 4 Xisco Faulí 2018-06-11 09:54:49 UTC
Also reproducible in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Mark Hung 2018-07-18 14:13:51 UTC

*** This bug has been marked as a duplicate of bug 33022 ***