Download it now!
Bug 118071 - Libreoffice impress does not save master slide settings
Summary: Libreoffice impress does not save master slide settings
Status: RESOLVED DUPLICATE of bug 111306
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-08 16:06 UTC by sk.griffinix
Modified: 2018-07-13 16:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sk.griffinix 2018-06-08 16:06:20 UTC
Description:
Libreoffice does not save master slide settings even after saving a document. When closed and reopened, default settings are used instead of saved settings

Steps to Reproduce:
1.Create slide(s) in impress.
2.Open master slide view and change background colour to black. It is observed that the background colour changes to black and fonts to white, as intended.
3.Close master slide view. It is observed that the new settings have been implemented in all slides.
4.Save the presentation in pptx format.
5.Close the window.
6.Open file again with libreoffice.


Actual Results:  
the slide background reverts to white

Expected Results:
Slide background should remain black


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
not tested in saving to .odp or .ppt.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 raal 2018-06-11 17:46:36 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: c4c56de1b0e62ec866b519b2b24c5e805f0a86d3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

works in LO 4.1, regression
Comment 2 Buovjaga 2018-07-12 18:45:35 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2018-07-12 18:47:30 UTC
(In reply to Buovjaga from comment #2)
> Already seen in latest commit of Linux 50max

Sorry, my brain does not work: I meant that the problem is not yet seen in latest commit of 50max.
Comment 4 Xisco Faulí 2018-07-13 16:25:49 UTC
The problem is reproducible if the background is changed from the sidebar, but not from the content menu.

Version: 6.2.0.0.alpha0+
Build ID: dbf8ad9bc385411c349095dfa66345464b4215d6
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

This is the same issue as in bug 111306, and it's not a regression

*** This bug has been marked as a duplicate of bug 111306 ***