Bug 118109 - Graph axis value markers not displaying correctly
Summary: Graph axis value markers not displaying correctly
Status: RESOLVED DUPLICATE of bug 117088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.0.3.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-06-11 09:40 UTC by zacgarbage
Modified: 2019-05-19 13:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word document with screen shots showing fault (262.00 KB, application/msword)
2018-06-11 09:56 UTC, zacgarbage
Details
Charts showing with and without bug (48.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-06-16 09:36 UTC, zacgarbage
Details
What is displayed by starting from scratch under Windows 7. (31.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-07-26 10:33 UTC, Jacques Guilleron
Details
a view from the previous file (21.38 KB, image/png)
2018-07-26 11:44 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zacgarbage 2018-06-11 09:40:58 UTC
Description:
The axes (X and Y) on linear point and line charts have been set up correctly with max, min, and major interval values all entered correctly. But the values do not show completely on the graph axes, either missing altogether or arbitrarily abbreviated, making the chart very difficult to read/interpret

Steps to Reproduce:
1.Nothing was knowingly done to cause the fault. It simply occurred of its own accord
2.
3.

Actual Results:  
The problem occurred without any known action taking place.  The chart settings were not changed, but the fault occurred

Expected Results:
As noted above, there were no steps to perform


Reproducible: Sometimes


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 zacgarbage 2018-06-11 09:56:42 UTC
Created attachment 142650 [details]
Word document with screen shots showing fault
Comment 2 Jacques Guilleron 2018-06-12 09:20:19 UTC
Hi zagarbage,
Can you provide the corresponding file, to make easy the test.
Thank you.
Comment 3 zacgarbage 2018-06-16 09:36:45 UTC
Created attachment 142789 [details]
Charts showing with and without bug

Apologies for delay. I needed to severely edit the file to remove confidential data which took some time.  Hope this helps to solve the problem
Comment 4 Jacques Guilleron 2018-06-18 16:09:25 UTC
Hi zacgarbage,
 
Negative labels are not displayed on Y axis and dates are truncated on X axis.
They are displayed when number format use 2 decimals and date Format use time datas.
I reproduce with
LO  6.0.3.1 Build ID: 62abb169b0efa1520d7bee1f586865354060b989
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
and upper versions
but not with
LO 6.0.2.1 Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 5 Xisco Faulí 2018-06-19 13:20:17 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=35d062f7879d5414334643cb90bff411726b2168 which is the same as in bug 117088.

Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 117088 ***
Comment 6 zacgarbage 2018-06-22 08:24:58 UTC
My bug report ([Bug 118109] "Graph axis value markers not displaying correctly") has been closed by Xisco Faulí as being a duplicate of this bug, said to have been resolved. But my bug is not resolved. I have carried out the suggestions ("They are displayed when number format use 2 decimals and date Format use time datas") made by  Jacques Guilleron, but this makes no difference to the incorrectly displayed axes major interval values
Comment 7 zacgarbage 2018-07-23 14:39:53 UTC
This issue remains unresolved (per the comments thread below).  The bug renders the graphing function very seriously compromised.  I should be most grateful if someone with particular expertise in the graphing function could sort it out.  Many thanks in anticipation
Comment 8 Xisco Faulí 2018-07-23 18:49:25 UTC
This bug will be resolved when bug 117088 is resolved, which it's not for the time being...

*** This bug has been marked as a duplicate of bug 117088 ***
Comment 9 Jacques Guilleron 2018-07-26 10:33:22 UTC
Created attachment 143779 [details]
What is displayed by starting from scratch under Windows 7.

So I guess this ssue is specific to Windows 10, since I dont reproduce from scratch.
Someone under Windows 10 can he confirm?
Comment 10 Jacques Guilleron 2018-07-26 11:44:02 UTC
Created attachment 143781 [details]
a view from the previous file
Comment 11 zacgarbage 2018-07-26 13:54:10 UTC
The problem is the same on both my PC (Windows 10) and my lap-top (Windows 7)for each of the graphs in the same spreadsheet(though I haven't "started from scratch")
Comment 12 Jacques Guilleron 2018-07-26 17:12:46 UTC
Thank you zacgarbage.
Can you then try to "Restart in Safe Mode..." (Help menu) to make sure there is no 
setting giving you a bad behavior?
Comment 13 zacgarbage 2018-07-26 19:24:04 UTC
I've started in safe mode, but it makes no difference.  The maximum font sizes for each graph axis needed to show the full scale remain as they are in normal run mode