Bug Hunting Session
Bug 118111 - Deleting columns in TABLEs with merged cells is broken
Summary: Deleting columns in TABLEs with merged cells is broken
Status: RESOLVED DUPLICATE of bug 46733
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2018-06-11 14:09 UTC by Christoffer
Modified: 2018-06-11 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example document (8.98 KB, application/vnd.oasis.opendocument.text)
2018-06-11 14:10 UTC, Christoffer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoffer 2018-06-11 14:09:32 UTC
Description:
Please see the attached example document.
It isn't possible to delete a selected column from a table if some adjacent cells are merged.
This issue does not affect Calc, only Writer!

Steps to Reproduce:
1. Create a 3x2 table.
2. Merge 2 of the 3 columns in one row.
3. Select and delete an un-merged column in the other row.

Actual Results:  
Many different and unselected columns are deleted.

Expected Results:
Only the selected column is deleted.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: sv-SE (sv_SE); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Christoffer 2018-06-11 14:10:17 UTC
Created attachment 142655 [details]
Example document
Comment 2 Xisco Faulí 2018-06-11 14:17:13 UTC
This is happening because when the columns is selected, cell A4 is selected as well.

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 3bd8759f5ed0393b2cc5560cab1b5d4052bd9728
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Xisco Faulí 2018-06-11 14:18:06 UTC
Actually, this is a dupe of bug 46733

*** This bug has been marked as a duplicate of bug 46733 ***