Download it now!
Bug 118126 - export as pdf text with pictures
Summary: export as pdf text with pictures
Status: RESOLVED DUPLICATE of bug 109143
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-06-12 09:59 UTC by bornolbers@gmail.com
Modified: 2019-03-16 19:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bornolbers@gmail.com 2018-06-12 09:59:24 UTC
Description:
I have a text with images from shutter. I crop images with libreoffice-writer's tool to fit my needs. At export as pdf process images reappeared un-cropped on pdf. On writer are showed fine. If I print the document to file and choose "pdf", the pdf is fine.

Two different ways to export to pdf with totally different results.

Steps to Reproduce:
1. import multiple images on writer
2. crop them
3. export to pdf with the button on panel
4. export to pdf through print-to-file
5. compare the results

Actual Results:  
all cropped images are un-cropped destroying the structure of the document

Expected Results:
as before (5x editions for sure) and as the print-to-file, export to pdf should have the same structure and appearance as the writer document


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Jean-Baptiste Faure 2018-06-12 10:33:09 UTC
Not reproducible for me with LIbreOffice 6.0.4 from Ubuntu PPA.

Please, attach a test file and your resulting pdf.

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 2 QA Administrators 2019-01-11 15:22:51 UTC Comment hidden (obsolete)
Comment 3 bornolbers@gmail.com 2019-01-14 10:29:37 UTC
Now I have ubuntu 18.10 and libreoffice 6.1.4.2 from Ubuntu PPA. With the current version the results are not reproducible. Do you suggest to test again ubuntu 18.04 with libreoffice 6.0.3.2 and upload the results? 

Best regards, Born.



ps. when qa administrator answers, I received an email and checked this out. I would like to receive an email on any answer (I do not know hot to do it or if it is possible) because only today I read JBF's answer. If I read it then, I would have replied instantly.
Comment 4 Timur 2019-01-14 11:00:50 UTC
bornolbers, if you can test, you're welcome. 
Easiest is to start with just different LO including daily master using https://www.libreoffice.org/download/appimage/.
It's good to attach a sample with reproducible issue. Please try with different image types.
I add Bug 45168 to See also. 
You should receive all messages since you are a reporter.
Comment 5 張修銘 2019-01-14 11:17:15 UTC
This bug sounds similar to Bug 109143. Maybe this is a duplicate and has been fixed?
Comment 6 Timur 2019-01-14 11:24:17 UTC
Should be tested with daily master or at least LO 6.0.5. If fixed, could be. 
If not, could be a duplicate of Bug 117059.
Comment 7 bornolbers@gmail.com 2019-01-14 12:24:21 UTC
From the files attached there, this bug sounds similar to Bug 109143 to me also. But I would find some time to test again LO 6.0.3.2 and LO 6.0.5 and let you know..

Thank's
Comment 8 Xisco Faulí 2019-01-17 11:20:26 UTC
Hello,
You can also try with LibreOffice 6.2.0.2 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases
Comment 9 Roman Kuznetsov 2019-03-16 19:18:42 UTC
(In reply to Xisco Faulí from comment #8)
> Hello,
> You can also try with LibreOffice 6.2.0.2 from
> https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases

don't repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 13a260f59e421f3e67845f8f2eb22b8f0f8fcaf0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-11_02:46:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 10 Roman Kuznetsov 2019-03-16 19:19:12 UTC

*** This bug has been marked as a duplicate of bug 109143 ***