Bug 118141 - Fields in "AutoCorrect options..." window are wrongly filled by LibreOffice
Summary: Fields in "AutoCorrect options..." window are wrongly filled by LibreOffice
Status: RESOLVED DUPLICATE of bug 78217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2018-06-13 13:21 UTC by Luca Sardelli
Modified: 2018-06-14 06:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
"AutoCorrect Options..." window with wrongly filled fields. (267.37 KB, image/png)
2018-06-13 13:30 UTC, Luca Sardelli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Sardelli 2018-06-13 13:21:27 UTC
Description:
I
- select a misspelled word;
- select "AutoCorrect options..." from "Tools" menu

LibreOffice
- display a window containing the fields "Replace" and "With";
- "Replace" field is empty;
- "With" field contains the misspelled word.

I would expect the opposite behaviour:
- "Replace" field containing the misspelled word;
- "With" field empty, so I can enter the proper spelling of the word.

Steps to Reproduce:
1.Select a (misspelled) word
2.Select Tools > AutoCorrect > AutoCorrect Options...


Actual Results:  
"AutoCorrect Options" windows opens;
fields are wrongly filled:
  - "with" contains the misspelled word;
  - "Replace" field is empty.

Expected Results:
"AutoCorrect Options" windows opens;
Fields should:
  - "Replace" contains the misspelled word;
  - "with" be empty.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no

Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Mac OS X 10.13.5; UI render: default; 
Locale: it-IT (en_IT.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Luca Sardelli 2018-06-13 13:30:50 UTC
Created attachment 142702 [details]
"AutoCorrect Options..." window with wrongly filled fields.
Comment 2 Dieter Praas 2018-06-13 15:13:09 UTC
I confirm the behaviour, but I' not sure, if this is a bug. If you have a word with right spelling, you would expect, that "Replace" is empty and "With" is filled. And how could LO know if it is a misspelled or just an unknown word?
Comment 3 tommy27 2018-06-14 06:53:13 UTC
this is not a bug.

I reported the same thing years ago but I was told that it was an intended behaviour.

see Bug 78217 - Autocorrect replacement table: selected text is copied in "With" field rather than "Replace" field

*** This bug has been marked as a duplicate of bug 78217 ***