Bug Hunting Session
Bug 118147 - [Writer] Changing Comments / Annotations Background Color
Summary: [Writer] Changing Comments / Annotations Background Color
Status: RESOLVED DUPLICATE of bug 61242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2018-06-13 15:59 UTC by Thierry Munoz
Modified: 2018-06-13 20:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Munoz 2018-06-13 15:59:07 UTC
Description:
I know that today the background color of annotations depends of the author.
But I think that it's too restrictive : to recognize different types of annotations, setting the background color will give better readability.

In Writer, it will be useful, for the same author, to choose the background color of annotations in order to have several colors to distinguish them more easily. Not only for the author but for the next user who will read these comments.
For instance, in order to help pupils to write texts and improve them, I would like to insert annotations with a specific background color depending of the error type : so the pupil will know easily what kind of error he made and he could choose the accurate tool for correction.

Now we have these main properties for the annotations : Author, Content, Date, Datetime, TextRange, ...
In first time, adding a new property for "com.sun.star.text.textfield.Annotation" like "background" could help to do the job with macros.


Regards,
Thierry

Actual Results:  
Impossible to fix the background color of comments/annotations

Expected Results:
With a new "background color" property for the annotations "com.sun.star.text.textfield.Annotation", we could choose several for the same author with macro.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Dieter Praas 2018-06-13 16:23:01 UTC
I suppport this idea. There are some similar bugs, like bug 61242 and bug 77488. Thierry, do you think we can treat your proposal as a duplicate or not?
Comment 2 Thierry Munoz 2018-06-13 16:50:02 UTC
Hi Dieter,
Thanks for pointing out these 2 older related bugs (I didn't find them : I looked for the word "annotation" not "comment", not "note"...).
I think indeed that it's the same problem so no problem to mark as duplicate.
Comment 3 Dieter Praas 2018-06-13 20:35:14 UTC
(In reply to Thierry Munoz from comment #2)
> Hi Dieter,
> Thanks for pointing out these 2 older related bugs (I didn't find them : I
> looked for the word "annotation" not "comment", not "note"...).
> I think indeed that it's the same problem so no problem to mark as duplicate.

=> DUPLICATE of bug 61242

*** This bug has been marked as a duplicate of bug 61242 ***