Bug Hunting Session
Bug 118206 - [GTK3] Calc hangs copying/cutting a conditional format column
Summary: [GTK3] Calc hangs copying/cutting a conditional format column
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: perf, wantBacktrace
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-06-17 10:47 UTC by Xisco Faulí
Modified: 2018-07-26 07:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-06-17 10:47:15 UTC
Steps to reproduce:
1. Open attachment 142790 [details] from bug 118189
2. Select Column A
3. Copy or Cut it

-> Observed behaviour: Calc hangs for a while. Not Reproducible with GEN, GTK or on Windows

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 1cf27cb44380f4a2bd6778c2dbbdef2a2a00cbc8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 1 raal 2018-06-17 11:10:04 UTC
No crash, Version: 6.2.0.0.alpha0+
Build ID: c4c56de1b0e62ec866b519b2b24c5e805f0a86d3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
My build is 8 days old, yours 3 days old. Maybe recent regression?
Comment 2 Xisco Faulí 2018-06-17 11:17:18 UTC
this is not a crash, a hang while copying/cutting
Comment 3 Xavier Van Wijmeersch 2018-06-17 13:58:11 UTC
when cutting/copying no hanging but when trying to use Ctrl+1 or direct cell formatting then LO is crashing

Version: 6.2.0.0.alpha0+
Build ID: 5bbf40fde5a6cefaf596c345f8997164dd92932f
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-17_11:17:04
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 4 malboarg 2018-06-18 21:02:47 UTC
I can not reproduce the bug in:
Version: 6.1.0.0.beta1
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2;
Comment 5 Xisco Faulí 2018-06-20 15:46:07 UTC
> Version: 6.2.0.0.alpha0+
> Build ID: 1cf27cb44380f4a2bd6778c2dbbdef2a2a00cbc8
> CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

I've just retested it with the same commit and I can't reproduce it anymore now.
Closing as RESOLVED NOTABUG
Comment 6 Commit Notification 2018-07-26 07:08:49 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96faaa6005465661d74b6dbf4879c43b85c68a55

uitest for bug tdf#118206

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.