Bug Hunting Session
Bug 118215 - Bullet points do not respect the language written from right to left in impress
Summary: Bullet points do not respect the language written from right to left in impress
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2018-06-17 21:00 UTC by MalangBadshah
Modified: 2018-07-14 10:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MalangBadshah 2018-06-17 21:00:54 UTC
Description:
I am trying to generate slides in Urdu language in LibreOffice Impress. Urdu is written from right to left. If I want to generate a bullet point, it always appears on the left side. The correct way for the bullet point to appear is on the right side. For details, please see the screenshot at https://ibb.co/cgteed.
Another related issue is that LibreOffice guesses the written language incorrectly (please see the screenshot above), the actual language in which the text is written is 'Urdu' but LibreOffice thinks the language is 'Hindi'.

Though, the bug appears in impress but I guess the behavior will be similar in 'writer' as well.

Steps to Reproduce:
1. Select a language that is written from right to left e.g. Urdu
2. Select a bullet point style
3. Start writing text, the bullet point starts moving towards left side, though it should stay on the right side.

Actual Results:
The bullet point is displayed on the left side in a language written from right to left

Expected Results:
The bullet point should be on the right side rather than on the left in a language written from right to left


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Buovjaga 2018-06-24 17:13:10 UTC
For now you can use View - Toolbars - Text formatting and set it to RTL manually
Comment 2 Eyal Rozenberg 2018-06-29 15:05:47 UTC
Judging by your screenshot, and the fact that I can't reproduce this, I speculate that you've chosen right-alignment but still have Left-to-Right direction. That's not incompatible with the screenshot and assuming that's the case, this is not a bug but intended behavior. If you want the _paragraph_, rather than some run of text within the paragraph, to be RTL - and thus get its bullet placed on the right - set the paragraph direction.

If I'm mistaken, please reopen and clarify what your alignment and direction settings were - page, page element (content box) and specific paragraph.
Comment 3 MalangBadshah 2018-07-14 10:36:17 UTC
Yes, you are right.Following the suggestion solves the problem. Thanks.