Bug Hunting Session
Bug 118327 - undo selects a list item
Summary: undo selects a list item
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
: 118349 (view as bug list)
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2018-06-23 08:48 UTC by lvm
Modified: 2019-07-17 10:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lvm 2018-06-23 08:48:49 UTC
Description:
pasting text into a bulleted list item and undoing it causes the list item to be selected

Steps to Reproduce:
1. create a bulleted list
2. paste some text into the middle of one of the lines of the list
3. undo paste

Actual Results:
undo works as expected, but the whole affected list line gets selected. Result is particularly startling when drag and drop is used - two noncontiguous areas get selected: the original selection and the list line into which it was dropped.

Expected Results:
list line should not be selected


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-06-23 13:50:50 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: b25f59094794eb72eefdbbbca8ac69eb325120c8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Dieter Praas 2018-06-24 18:33:10 UTC
*** Bug 118349 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2018-07-07 16:03:31 UTC
Problem is seen in the oldest commit of 43all
Comment 4 QA Administrators 2019-07-08 02:48:57 UTC Comment hidden (obsolete)
Comment 5 lvm 2019-07-08 05:45:57 UTC
Fixed in 6.2.4.2/linux
Comment 6 Harald Koester 2019-07-17 10:38:05 UTC
Was also bug with Windows.
WFM since version 6.1.1. with Win10.