Download it now!
Bug 118380 - Fatal error: Bad array new length
Summary: Fatal error: Bad array new length
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta2+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-25 19:38 UTC by Telesto
Modified: 2018-06-28 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (1.26 MB, application/vnd.oasis.opendocument.text)
2018-06-25 19:39 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-06-25 19:38:44 UTC
Description:
Fatal error: Bad array new length

Steps to Reproduce:
1. Open the attached file (odt export of bug 92433)
2. Go to page 61
3. Select everything to bottom
4. Press Backspace
5. Right click: ANNEX F – Portrayal Catalogue (last page)
6. Accept changes -> Error (or after scrolling up)

Actual Results:
Crash

Expected Results:
Probably not


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 7414e07f52af87094240f5c3d9a0eb764e8642f5
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-24_01:44:59
Locale: nl-NL (nl_NL); Calc: CL

No repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 1 Telesto 2018-06-25 19:39:13 UTC
Created attachment 143112 [details]
Example file
Comment 2 Jean-Baptiste Faure 2018-06-25 20:16:14 UTC
Crash reproducible with LO 6.2.0.0.alpha0+:
Version: 6.2.0.0.alpha0+
Build ID: 03c14b836ab03735870b36c2388fd88782b97550
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded

No crash with LO 6.0.4 from Ubuntu PPA.

Crash with LO 6.1.0.0.beta2+ but need more scroll than the master
Version: 6.1.0.0.beta2+
Build ID: 8f56cf1f5b29326371b9c29e2b9ccd81ed760941
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

status set to NEW.

Best regards. JBF
Comment 3 Xisco Faulí 2018-06-27 22:00:37 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 6ebc026e34d0c119067e7dfbad8d932f92844760
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 4 Xisco Faulí 2018-06-27 22:07:05 UTC
No problem in 

Version: 6.2.0.0.alpha0+
Build ID: b047ae6e5bde45555a20a9ad8b7d570d93496187
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

either...

Wondering if I'm missing a step or something...
Comment 5 Buovjaga 2018-06-28 09:21:54 UTC
No repro

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 4600b07c1d787f959618d9ecf54161e4ea4ffa61
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 28th 2018
Comment 6 Telesto 2018-06-28 09:59:30 UTC
No repro 
Version: 6.2.0.0.alpha0+
Build ID: 7e1cabd96526cb7befc5ea5073358093efbe12d0
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-27_23:39:20
Locale: nl-NL (nl_NL); Calc: CL