Bug Hunting Session
Bug 118384 - Sidebar: Style is not added back to hierarchy after deleting and redoing it
Summary: Sidebar: Style is not added back to hierarchy after deleting and redoing it
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords:
Depends on:
Blocks: Sidebar-Styles Undo-Redo
  Show dependency treegraph
 
Reported: 2018-06-25 22:00 UTC by Xisco Faulí
Modified: 2019-08-15 11:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-06-25 22:00:39 UTC
Steps to reproduce:
1. Open Writer
2. Go to Sidebar - Styles and make sure Hierarchical is choosen
3. right click on a style - new -> a new style is added a a child
4. Undo the action using Ctrl + Z -> the issue with the undo icon is covered by bug 47807
5. Redo the action

-> the style is added to the bottom of the list instead of as a child as before.

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: dbfa1c452fd9d02330cb3ec5bf2fd4f2c7782d1a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Dieter Praas 2018-06-26 07:41:56 UTC
I confirm it with

Version: 6.1.0.0.beta2 (x64)
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (de_DE); Calc: CL
Comment 2 hasan md mahamudul 2018-06-26 07:43:05 UTC

*** This bug has been marked as a duplicate of bug 112233 ***
Comment 3 QA Administrators 2019-06-27 02:53:44 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-06-27 07:53:10 UTC
Still reproducible in

Version: 6.4.0.0.alpha0+
Build ID: ea19b0c0230fcc730245ecd445c03164cb6a1d18
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jim, I thought you might be interested in this issue...
Comment 5 Jim Raykowski 2019-07-24 22:53:55 UTC
Here is a patch for this: 
https://gerrit.libreoffice.org/#/c/76279/
Comment 6 Commit Notification 2019-08-06 18:45:17 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c4d82fc21c5e155472f6a30244b3fce806ada85c%5E%21

tdf#118384 Fix paragraph, character, and frame style undo redo

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-08-14 15:41:50 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/bd4f9c7c77a28db3a927faa6cc63e02015b65e76%5E%21

tdf#118384 Fix paragraph, character, and frame style undo redo

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-08-15 11:31:54 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: fe00a724a918606e5c8c2c32b155bc50b33d56bd
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jim, thanks for fixing this issue!